Linear Scale Problem

I think the Linear Scale Component has a little problem:

When using the Indicators dataset with Style=Range everything works perfect if the Min Value of the scale is zero, but if you set the scale differently, lest say Min=50, Max=100, the indicators dont display correctly.

Another thing, perhaps I just dont know if I’m doing the right thing but I tried to set up a Cell-Update Binding with the indicators dataset, and I set the extent property of a indicator to this expression:
{Root Container.Group.EscalaTemp.maxValue} - {Root Container.Group.EscalaTemp.minValue}

the result was only the first part {Root Container.Group.EscalaTemp.maxValue} and ignored the second part of the substraction {Root Container.Group.EscalaTemp.minValue} which is not zero.


Good eye - you’re right the linear scale wasn’t calculating it’s indicators correctly when the min value wasn’t zero. I’ve fixed this for 7.3.2.

I’m not sure what the other problem you mentioned was though. Perhaps you could demonstrate it on a simple window and post that exported window here so we could take a look?

Hello Carl,

Thanks for your reply.
I’m attaching a sample window. To make it work correctly, please set minValue of the linear scale “EscalaTemp” to 0, so you can see what I tried to accomplish. Then set it to 20 and try it out again.

Also, you can see here what I mean:

Thank you.
SampleWindow.vwin (12.9 KB)

Ah, I get it now. The reason that’s not working is because…it’s not supported. You weren’t supposed to put an arithmetic expression in there - just a link to a property. Anyhow, you’ll have to make dynamic properties bound to expressions to do the subtraction, and then use those in the cell-update binding.

Thank you very much Carl.

I should have think about that solution, hehe.

Thank you!