Linux installation

First time installing Ignition on linux / raspberry pi using download " [Ignition Edge - Linux AARCH64.zip"
Followed all instructions until starting ignition: “WARNING: Ignition-Gateway may have failed to start”

Wrapper log, inter alia, states “License error.: A valid license was not found in the Wrapper configuration file. The Java Service Wrapper requires a License Key to activate the software. …”

Do I need to install Java? I understood that was no longer required.

Any other suggestions please

What hardware version of RPi are you using and what OS do you have installed?

More than likely, you’re running the 32-bit version of Raspberry Pi OS (64-bit is still in “beta” so you have to dig a little to find it on their website). In that case, you’d need our 32-bit ARMHF install.

If you can post the output of uname -a from your terminal along with the info @Kevin.Herron mentioned, it would be useful for helping troubleshoot.

I’ve got the 64bit beta loaded up on a Pi right now, haven’t gotten to test Ignition on it yet, but I am hopeful :slight_smile:

Hardware: R Pi 4B 8Gb
OS: NOOBS

Linux raspberrypi 5.10.17-v7L+ #1403 SMP Mon Feb 22 11:33:35 GMT 2021 armv7L GNU/Linux

@jrd, armv7L indicates a 32-bit host OS… Try giving the Ignition - Linux ARMHF 32-bit zip (1458MB) install a try!

Or, since you’re on an 8GB Rasp Pi 4 (NICE :slight_smile: ), unless you’ve got a lot of other things setup on there already, you might try installing the 64-bit beta that @dkhayes117 mentioned above…

Hmm, I just downloaded the client launcher for Linux on 64bit RPi, and executing the clientlauncher.sh file yields

clientlauncher.sh: 4: clientlauncher.sh: Bad substitution 
clientlauncher.sh: 7: clientlauncher.sh:  [[: not found
clientlauncher.sh: 13: clientlauncher.sh: [[: not found

Launchers don’t run on the RPi, only the gateway does. Or a Perspective session in a web browser.

You’ll have to launch the Designer or Vision Client elsewhere.

(there is a bit of a hack floating around to launch a Vision Client via shell script and your own local Java install, though…)

I’m still on v7.9 and I’m pretty sure I used the native client launcher on the 32 bit version of RPi.
I must be missing Java.

1 Like

OOPS
My first post stated the incorrect Ignition download
I actually downloaded “Ignition-linux-armhf-8.1.3.zip”.

I only want Gateway on the Pi. The designer will be elsewhere.
I prefer to stick with 32bit as there will be other stuff on it and I don’t want beta 64

So the original problem remains:
“WARNING: Ignition-Gateway may have failed to start”!
… and error log appears to blame Java

One thing I have noticed is that on a fresh unzip, if you first attempt to run the gateway in the console with ./ignition.sh console, it does not decompress the JRE and you’ll end up with some errors related to java. You can force the JRE unpack with ./ignition.sh checkRuntimes. If you’re installing as a service with systemd (to run on startup), then it takes care of this automatically.

Here is a little run-through of an install on a Pi 4 (Raspberry Pi OS, 32-bit) that hopefully can provide you some helpful insights. This includes making the gateway run as the pi user instead of root.

asciicast

I tried that. results

and journalctl contents:

==> FAILED TO START IGNITION-GATEWAY

(Did you also make the adjustment to the systemd definition, User= directive?). Let’s also see the tail of the wrapper log:

tail -n 50 ~/ignition/logs/wrapper.log

… that should help show us exactly what the Ignition service itself failed with.

Hi Kevin
No I did not adjust systemd definition
I am new to unix, and did some searches but still don’t know what to do
Could you provide procedure

I got mine running on a Raspberry Pi 4 8 GB, w/ Ubuntu Groovy for ARM

I reinstalled from scratch on clean system and all worked fine.
Not sure what caused the issue ……
Thanks for the assistance