Location of Project folder under "Program Files", why?


I am just curious why the Ignition team chose to have Projects (or even data folder) under “C:\Program Files\Inductive Automation\Ignition” instead of “C:\ProgramData”?

We use bitbucket as repository for projects and cloning projects on Projects folder requires us to give special permissions, without which Windows tries to protect any changes to Program Files folder.

Would be less hassle, and probably right way to do, if “data” folder was under ProgramData.

It’s just a default. You can change it; in ignition.conf you can pass the parameter data.dir with a different value, e.g. wrapper.java.additional.6=-Ddata.dir=$someOtherDataDir.

We’ve found that, in general, having the default install put things in one place is a lot easier than trying to go down the rabbit hole of putting things in the myriad different OS-specific locations things might be “expected” to reside.

Thanks for the quick response.

I changed the line to:
wrapper.java.additional.1=-Ddata.dir=-"/Users/user name/Documents/Projects"

Could not find -/Users/user name/Documents/Projects\gateway.xml or -/Users/user name/Documents/Projects\gateway.xml_clean.

Do I need to copy the contents of data folder to this new folder?

You’re telling Ignition “all of your persistent configuration data is stored in this location, now”. If you don’t move the data, then Ignition won’t have any data to refer to.

I don’t think QA tests around this, particularly, so there may be some rough edges, but it will work.

OK so I copied the files.
I restarted the gateway.
I launched the designer
I see the files get updated (it asked me to recreate user, etc)
I created a new Project, but it still goes to original folder instead of new one. Seems like there is a separate configuration for Project folder?

Hmm. So, guess I missed something; you can force just the projects to a different directory (via ignition.projects.dir flag, set the same way as the data dir flag), but if you aren’t specifying that override then it should be using $data/projects.

1 Like

Great! That worked. Thank you very much. Good work around for Windows OS.

1 Like