Locked out of local gateway

I restored a backup from a customer site gateway locally as I overwrote some windows accidentally.
However I cannot login to it locally as the local gateway cannot verify my login info. Reason being Active Directory authentication was used in the customer site, I noticed in the wrapper log files, it failed to connect to LDAP server
Now I can’t even restore any other backup since I am locked out. Is there any way to access the local gateway ? Or Is uninstalling/reinstalling Ignition locally my only option ?

You can reset the password using the GCU or gwcmd depending on what version of Ignition you are using.


1 Like

Thanks for the quick reply. I can access the gateway now after password reset
However it gives me a connect error when I try to launch Designer
ConnectionException: Connection Refused

What version of Ignition are you using? The Public HTTP Address setting for the gateway may be set to something you can’t resolve locally.


Another thing that may be set is the https/ssl certification. I had this happen a few months ago where we were using http/https and it was not letting us in when we had bad certs.

that seems to be greyed out for me, its enabled though

So it appears that it is enabled and the designer wants to connect through the https port. The easiest thing to do is to stop your gateway, edit the https stuff in the ignition.conf file to remove it, then start the gateway again. I dont have a gateway right in front of me to pull the conf file and post it here so I cant post an example right now.

ignition.txt (8.2 KB)

I tried searching for https in the conf file, but had no luck. I have uploaded the conf file to this reply

@indra.biswas My bad on the file. I was thinking of the file gateway.xml in the ignition data folder but mixed them file names :slight_smile: I guess I should double check my work.

Make sure the lines in that file are similar to this. I had issues with my designer / client not wanting to connect (though the web portal was fine) and when I called support, this is what they had to change.




you da man. i can connect now
the entry to be updated was
to true.

@indra.biswas Glad I was able to help.

Guys, we used this post today. It helped us get out of a pinch. Thanks for sharing.

One caveat is that depending on your companies security policy, you may need to modify the read write permissions of the file in order to be able to modify it (in our case yes)