Mac OSX - NCL Does Not Launch Project

I am migrating completely to the NCL, but I am a complete novice when it comes to Mac computers.

I am using the method mentioned here for all of my Windows installs, but I’m not sure what I’m going to do about Macs.

I’ve tried just installing the NCL on a Mac that I can work on, but I can’t even seem to get that going.
I have installed java but I get this error message and nothing happens when I try to launch a project out of the Native Client Launcher:

Does anyone have any suggestions for getting it to work in general, and also suggestions for a package that I could distribute which launches with all of the necessary arguments set? (gateway.addr=myserver project=myproject , etc)

I appreciate your help,

It looks like java may not be on the path. How did you install java (recommend homebrew if possible)? If you echo $JAVA_HOME at the terminal, does it give the correct path? What version of java is reported with java -version?

I just installed it from the web at

echo $JAVA_HOME just leaves a blank line.

java -version yields:
“No Java runtime present, requesting install.” with the same result as the error message above.

Looking through some Java documentation (command line java on mac), it looks like you have to have the jdk installed, not just the run time environment to use the command line tools.

Or is it possible to just add java to the path?

Thanks for the response Perry.

The easiest way is to just add the JAVA_HOME path export to your ~/.profile file, which is executed when you start a shell session. Most commonly that export is just adding a line ```
export JAVA_HOME=$(/usr/libexec/java_home)

On mac,  `java_home` symlink should point to the correct current version.

  As mentioned, I generally find that installing via `brew cask install java` (using the popular homebrew package manager to be the best allround installation route if not using jenv.  The java that comes with Mac by default is pretty old IIRC and I am not sure it will be sufficient for Ignition.

I checked out Homebrew, and installed that, and then installed java through that as you suggested.

That all seemed to go smoothly, but I’m getting another error:

I checked
and it returned with a blank input, so I followed your suggestion to set the path with the export function.
$JAVA_HOME and java -version
both seem to show valid outputs now, but I’m still getting the same error as above.

-Rob W.

Make sure you’ve removed all other Java versions from your system - especially Java9+ if you’re not yet on 7.9.6.

Just to make sure we understand what you’re seeing, what are the outputs from the following commands:

which java
java -version

Also, it may be helpful for you to enable the java console, and then posting the output of one of your failed launches. To enable the console, open up your system preferences, and click on the Java section. Then in advanced, you want the console set to show:

Can you try logging in as a new user in OSX and try there? Does that work for you?

Hey guys, I gave up on this thread due to lack of necessity from my customers.

I now have a customer who must have the MAC version.
I got the NCL installed and it’s running and even connecting to my server. Unfortunately, I have hidden all of my projects so they don’t show up in the NCL page.

Is there a way to create a shortcut link on a MAC which will automatically launch the NCL, connect to my Server, and select the correct Project? (Just like I currently do in Windows?)