MAI Binding trouble

I’m trying to create a sort of automatic Moving Analog Indicator and if you’ve worked with them, then you know that pretty much for all non-range high, range low and process values you can just delete the number in there, making the field effectively blank, then the MAI will ignore it. So you don’t have to set a setpoint value, high alarm, etc.I’m trying to bind these fields to essentially a script, where that script decides if the value should be overridden and given a blank value. However, it seems like no matter how I try to make the expression work it will populate with a 0, instead of being blank.

I’ve tried an expression just equal to ‘’, I’ve tried a completely blank expression, I’ve tried runscript("’’") (thats two double quotes surrounding two single quotes), and a couple more things I can’t remember right now.

I just want to write a blank value here… Any ideas? I know I can (because this was my previous method) just use scripting to assign these fields to blank values in a script but that was causing a slowdown for me so I’m trying to use more expression-based than script based things where I can.

Edit: I’d still like to know if theres a way to do this, but I just came across a hacky but working-so-far solution. For things like high alarm, desired high etc if I want to ignore it I’ll just set the value really high, or really negative for low things.

If you are trying to set the value from a script, you might try setting it to the keyword ‘None’. That’s how Jython indicates a null value. I don’t recall the keyword for the expression syntax, if that’s how you are setting it though.

Here’s a thread discussing a similar problem to yours. Looks like setting to either None or Null was the answer for them.

Nice, thanks! That works.

1 Like