Maps marker icons not showing

Hi there,
I’m playing with the Maps component in perspective.
I was able to add markers with icons as expected.
The problem is launching the session. The marker icons don’t show up. The markers are there because clicking on them the events are firing, but the icons are missing.
Randomly they appear, but at the moment I click or zoom, they disappear again.

Any ideas?

I am also having this same issue, when ever I click on marker to open a popup they all disappear and take a long time loading back in. I’m using 8.0.10

You might try clearing your browser cache. Whatever icon you’re using might not be loaded in the cached list of icons stored in the browser. You could try using another icon, something basic, and see what happens. We’ve fixed the caching issue in 8.1. I’m not sure what version you’re using.

I have the same issue.
Markers don’t show…
In Perspective I can see them, but when I use WebBrowser in Vision Window, it’s just invisible, but on mouse hover event I can see the tooltip…

I tried to change icon, but nothing helped…

I tried to delete Web Browser and paste the new one, so I get this:

11:27:10.326 [Browser Thread: 49549] INFO WebBrowser.BrowserComponent - Web browser frame failed to load. Error = ABORTED, URL = http://ip:8088/data/perspective/client/projectName/vision/clientID

ip, projectName and the clientID are correct.

This happened after Ignition version was updated to 8.1.0

I created new page without any scripts and so on…
I did add a new clean map without any markers on it and pasted new Marker manually…
so when I tried to see the result in browser, so I get clen map without any Markers on it…

Designer:

Browser:

I reinstalled Perspective, Vision and Web Browser Modules… and nothing was changed…

What’s wrong???

image

I think you’re encountering an issue we’re already working on. We recently made some improvements to the way icon caching is handled, but we’ve noticed that a couple of components which use icons internally are not using the new caching protocols correctly. We’re fixing it as part of 8.1.0.

Thanx for Your replay!
We will wait for it! :pray:

Fix was merged today and will be part of 8.1.0 when it is released early next week.

1 Like