Matplotlib failure

Morning Guys,
This looked like an appropriate location for this question...

What in the world is this?

I believe that matplotlib makes use of DLL files, therefore you can use it with pure Python, but not Jython, which Ignition uses.

I don't understand how you concluded a post about gateway startup had anything to do with a client/designer issue. It doesn't.

If you share more information how you got to this state, we might be able to advise further. Complete Ignition version, to start.

Designer would not start spouting the gw~ path issues... or // gateway fails to respond

Could you open the gateway web page? If so, it started.

Launching a designer doesn't test a gateway's status, it tests comms to a gateway. There's lots of ways a designer launcher can screw that up.


i opened my Machine this morning and clicked the Designer Button and received that error. i examined the folder of the PyLib and most of it is empty besides the matplotlib directory.. I looked on my clients installed system to validate the missing directories.

The error shown is to a gateway in your own machine, not a gateway elsewhere. Open http://localhost:8088/ in web browser. What do you get? Is it what you expect? What designer shortcuts do you have in your designer launcher? Is localhost one of them? Where is your client's gateway?

  1. It Opens the Gateway on my Host machine for sure.. Yes Gateway opens and seems functionl
  2. 1 shortcut and localhost is the path
  3. i have rdp'd into another machine off their network while i complete this install
    the folder in the error: LH is my Host | RH is the Other install (Client Machine)


They are doing something odd with CPython on their gateway and have tied it to Ignition somehow.

Try deleting matplotlib from your device, deleting your launcher cache, and trying again.

If that fails, you will have to closely examine what happens when launching a designer against their production server to figure out what it is doing, and replicate the necessary pieces of that environment in your environment.

You might want IA support looking over your shoulder.

(FWIW, running a gateway directly in your workstation is unwise for anything except training material. Set up a separate VM that closely mimics your client's real production gateway server and run just the gateway on it. Run just the designer on your workstation.)

Sorryit seems i mislead the conversation.
i am working only on my Dev machine. where the issue is. i built their PC last week to run this app.. , so when i ran into this issue i went to that machine to review the same directory..

Again Sorry

So, the content of the local gateway was all developed by you? And you didn't put any matplotlib reference in it?

Is your anti-virus current? Anyone else have access to your machine?

Yes sir.. 100% by me. i do not recall installing matplot directly??.. the other machine was a Fresh HDD install and WIN 11 last week. I only installed Sql server and Ignition however, the Matplotlib folder is present on that machine. Could it be a recent ignition update?

My Machine "CCC-CTRLS-RW-WIN10" is the Squirrley one this morning.. (VM for sure)


It's not part of Ignition, it's part of whatever backup you are running/restoring.

Have you tried closing the Designer/Launcher, deleting the local .ignition folder, and then attempting to launch again?

1 Like

No i had not. Neither worked after deleting the .Ignition folder (fyi) . No Gatway / Designer.. Im going to a Snap shot of my vm for now and take this up later when im not on site.

On the MatLib thing i will have to ask my daughter (she built the Core for me from other HMI Software packages and maybe she needed something i was not aware of?)
Thanks for the help guys,
Happy Sunday!