Max time between samples

Why does setting the sample mode of a tag to Tag Group hide the “Min time between samples” and “Min time units” fields, but not the Max Time equivalents? I would have thought that since all 4 are in the tag group, they would all be hidden. Is this an override that’s needed in some cases while Min Time overrides are never needed/don’t apply?

Given that the max time has to be set on both the tag group and on the tag, which one takes precedence?

1 Like

Apologies for the bump, but does anybody know the answer to this? I can’t find it in the documentation.

I had this same question and found this post. Based on a quick test of setting the tag’s max time above or below the tag group’s max time I saw no change to the sampling - i.e. the tag group’s max time is always used. I think hiding this option in the tag config was just missed by the developers in the underlying implementation (unless I’m missing something).

It just means it can record as fast as the tag group can deliver the data, if it is changing on every sample. The tag group’s pace would govern.

I think @mschell1978 might be right that they’ve just forgotten to hide it or forgotten to wire it up or something. The max time works on the actual tag, but the tag group’s value doesn’t seem to take precedence over the individual tag from what my testing could gather.

There may be a bug here. Ran some quick tests. If you create a new tag group and leave it with all default values, the max time setting on the individual tags work as expected. As soon as you touch the max time setting on the tag group, the tag group setting always takes precedence over the individual tag setting, even if you change the setting in the tag group back to the default of 0 hours. Restarting the tag had no impact. I haven’t tested to see if touching any of the tag group historical settings will cause the same behavior.

Tested on 8.1.5.

Edit: Seems like there should be a property on each tag that determines if the max time setting should override the tag group setting. Not sure how feasible that would be.

Does anyone know if there is a way to force the system to respect the historical max time setting on an individual tag once the tag group historical max time has been touched? Resetting the tag group to default values doesn’t do the trick. I haven’t yet tried restarting the gateway after setting the tag group to default settings.