Maximum available memory in designer

When I open a project in the designer, I am getting a maximum available memory of 494 mb. But the Designer Memory setting for the Gateway is 2.0 GB. I have tried adding the following command-line arguments when I launch it, but this didn’t help:

javaws.exe -Xms1024m -Xmx2048m http://ignition/main/system/launch/designer/designer.jnlp

I have both Java 1.7.0_60 and 1.6.0_45 installed on my VM, and I get the same result using either one.

Is there some other setting I’m missing that would affect this?

Try this: javaws -uninstall designer.jnlp and download and run the designer.jnlp again. Sometimes Java Web Start gets finicky about its local cache files :scratch: If that doesn’t work, open the designer.jnlp and verify that the initial-heap-size and max-heap-size settings are what you expect, as that file is generated on the fly from the Gateway.

When I run that command, I get an Application Error pop-up, saying “Unable to completely uninstall application.” The pop-up has a Details button, but it just closes when I click on it. And it’s still the same situation when I start up: used is 76 mb, maximum is 494 mb.

Try uninstalling all without specifying the designer.jnlp

javaws -uninstall

and see if that gets it out of there. Note that his will take out all of the jnlp’s, so if you have shortcuts on the desktop, you’ll need to relaunch the projects to get them back.

I just tried that, and while it did remove the shortcuts, I’m still getting the 494 mb maximum.

If you download designer.jnlp and open with a text editor, what do the memory settings look like?

It looks like these are the applicable settings:

<j2se version="1.6" initial-heap-size="64M" max-heap-size="2048M" java-vm-args="-XX:MaxPermSize=128m"/> <j2se version="1.5+" initial-heap-size="64M" max-heap-size="2048M" java-vm-args="-XX:MaxPermSize=128m"/> <j2se version="1.7" initial-heap-size="64M" max-heap-size="2048M" java-vm-args="-XX:MaxPermSize=128m"/> .... <property name="" value="64M"/> <property name="" value="2048M"/>

Sorry, have another test for you to run. On the command line, run

javaws -verbose designer.jnlp

and post the Java Web Start window here. That should show how much memory the main Java application is given when it is started.

I don’t see anything in there giving the memory allocation, but here’s the Web Start screen:

Your verbose output looks very different than what I see on my systems. I am somewhat confused on why it can be so different. Can you PM me the contents of your designer.jnlp file? Also, can you include the version of Ignition that you are currently running?

Mystery solved! My _JAVA_OPTIONS environment variable was set to “-Xmx512MB”, which capped the memory at under half a gig. Removing this option caused it to fail to launch at all, which eventually led me to figure out that I was running a 32-bit JRE on my 64-bit virtual desktop. I downloaded a 64-bit JRE, uninstalled the old ones, and I’m back in business with 1824 MB of memory available in my designer. :thumb_left: