MES Production Model Not changing into Run State

I installed the MES modules and configured the SQL database connection in MES Settings in Gateway. Now, i configure the production model in the designer client, and enabled the production model, but its not changing to running state. The alert shows : “Production model stopped. Check the MES settings in the gateway.”

Note: I Could see the configured production model components in the SQL database table, so the connection to the database is live, but the production model still is in stopped state. Also, i tried restarting the Production model and Ignition Service, but nothing helped me in solving the problem.

Did anyone else face the same problem or what could be the possible reason for it?

Hi Vijay, which version of Ignition and which version of the MES modules are you using? Have you checked the wrapper.log file to see what happens when you enable the production module? There may be a clue there that you can post here to help us troubleshoot.

Hi Roy,

Thanks for the reply.
I am using Ignition version 8.0.10. I even tried uninstalling the modules and then installing them again, but nothing seems to be working out…!! I am copying a snapshot of my wrapper log below for your reference which i suspect a problem.

[08:59:47]: Starting up module ‘webservicegateway’ (v2.80.0 (b1910222139))…
[08:59:50]: Starting up module ‘webservicegateway’ v2.80.0 (b1910222139)… module-name=Web Service
[08:59:50]: Starting project: MESGateway project-name=MESGateway, project=MESGateway
[08:59:53]: Restarting gateway scripts… project=MESGateway
[08:59:53]: Project started. project-name=MESGateway
[08:59:56]: Restarting gateway scripts… project=TestMES
[09:00:09]: Creating auto-backup of internal database “config.idb”…
[09:00:10]: Created auto-backup of internal database “config.idb” in 1 seconds
[09:00:22]: Installing module: “productiongateway”
[09:00:23]: Starting up module ‘productiongateway’ (v2.80.0 (b1910222139))…
[09:00:24]: Module “productiongateway” depends on “xopc”, but it doesn’t exist.
[09:00:32]: [Production] Starting up…
[09:00:34]: Starting up module ‘productiongateway’ v2.80.0 (b1910222139)… module-name=Production
[09:00:34]: Production module startup
[09:00:34]: Using ‘default’ as tag provider
[09:00:34]: Redundancy is not enabled - starting production model.
[09:00:35]: Verifying MES object schemas…
[09:00:35]: Unable to check availability of null datasource (Analysis).
[09:00:35]: Error starting MES object manager.
| 2020/04/21 14:30:35 | java.lang.NullPointerException: null

Does this have something to do with my problem?

It looks like you’re using an older build of the production gateway that likely isn’t compatible with your version of Ignition.

In fact, the latest version supported by the Sepasoft modules is 8.0.9

1 Like

Hi Jonathan,

Thanks for that finding.

I am using the sepasoft modules V2.80.0. Yes, you are correct, if i select Ignition V8.0.10, it says no supported sepasoft modules for this ignition version.

So does this mean that i need to downgrade my Ignition to V8.0.9 to work with the sepasoft modules??

If you can, I would certainly try to that to eliminate version incompatibility as an issue

Ok, thanks. I will try that and come back with the result…!! :slight_smile:

We have tested 2.8 SP2 ( 8.0.10 and it runs, SP2 was specifically created to work with the changes in 8.0.10. Though sepasoft do not guarantee all features work, so your best course is to downgrade to 8.09 and use the tested and confirmed working 2.8 sepasoft modules.

Hi everyone, thanks for those valuable suggestions. As you guys suggested, downgrading the Ignition version to 8.0.9 solved the problem…!! :slight_smile: