Micrologix Connection: "Disconnected: Determining Protocol"

Dear Ignition gurus :prayer:

Version: 7.6.0 (b1875)
OS: Ubuntu 12.04.2 LTS

I have just setup my first Ignition project talking to a mixture of Control/Compact/MicroLogix PLCs. Setting up the devices I have put the IP address as the host names and changed the timeout to 10000 for all controllers.

The Control/Compactlogix devices appear to connect fine. However, the 3 Micrologix 1100’s and one Micrologix 1400 suffer a connection error:

The error cycles between:

“Connecting: Determining Protocol”
“Disconnected: Determining Protocol”

The problem controllers are SH1,SH2,TW1,TP1 below are the expanded details on TP1 which is the ML1400:

All the ML PLCs have roughly the same error as above.

I am considering upgrading the firmwares of these PLCs in an attempt to rectify, as all of these PLCs are series A (old).

Before I start booking plant downtime, can you please cast your eyes over this error and offer advice?

Thanks team.

Mathew Kent

Under ‘Connectivity’ in the UA config for those devices, try setting
Connection Path to 0

In the advanced settings for MicroLogix there’s an option called ‘UseZeroTNSConnections’ or something to that effect… you can set this to true and it might enable you to get connected to these series A firmware devices.

If that doesn’t work, then yeah, go ahead and schedule some downtime for an upgrade.

Dravik and Kevin,

The ML1100s with a combination of both your solutions progress to:

“Connecting: Protocol: Bridged_EIP” in the device status.

The ML1400 works when just checking the ‘UseZeroTNSConnections’ option. Adding in a path of 0 gives the same error as the ML1100.

In the ignition designer OPC tag browser I can browse the ML1400, however, the ML1100s only show the “Diagnostics” folder.

In short it looks like the ML1100s will need a FW update, where as the ML1400 (series A) is working with ‘UseZeroTNSConnections’ ticked.

Thanks for your suggestions. :thumb_left:

Mat Kent.