MicroLogix ENI driver not communicating


I’m trying to connect to a MicroLogix PLC, not sure which model it is at the moment, will be able to find out next week.

Comms is via an ENI module, but I can’t get i to talk using the MicroLogix driver.
Status goes from Connecting: Determining protocol to Disconnected: Determining protocol

Error in log is this:

MicroLogixDriver Time: 27Jul2017 15:13:45 
Message: Error connecting to "".
java.net.ConnectException: Connection refused: connect
at java.net.DualStackPlainSocketImpl.connect0(Native Method)
at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.SocksSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at com.inductiveautomation.xopc.driver.api.AbstractSocketDriver.connect(AbstractSocketDriver.java:113)
at com.inductiveautomation.xopc.drivers.allenbradley.MicroLogixDriver.connect(MicroLogixDriver.java:142)
at com.inductiveautomation.xopc.driver.api.AbstractDriver$5.run(AbstractDriver.java:672)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Any help would be great, thanks.

Have you restarted the ENI module? Verified the IP address is correct? You aren’t even able to open a TCP connection to it at this point.

I believe you have to disable browsing in the OPC device for ENI modules.

The plc is already talking to another scada package and I can ping the module from the ignition gateway server. I’ve tried both the advanced options. Could it be that the Eni module has maxed out already on its number of connections?

Might be a ongshot, but I resolved a similar situation last week by removing the “no ip proxy arp” from the vlan on my switch that the plc’s were connected to. We’re a Cisco shop.