Missing menu "Project > Properties > Client > General"


For a reason i can’t figure, today, this menu has dissapeared from the Designer. All other menus are available but this one (Properties > Client > General) is not here anymore.

I’ve tried to :

  • Restart the Gateway
  • Restart the Server
  • Uninstall the Gateway, deleted all Ignition files i could find and then reinstalled Ignition (7.4.4 (b1017))

None of these allowed to get this menu back.

Any ideas ?

That is a strange one. Take a look at the log viewer in the designer (help -> diagnostics -> log viewer) and look for an error in the PropertyEditorDialog logger. It should say something like “Error creating dialog editor page”

Let me know what you find. If the error is there, post up the full stack trace.

Error creating dialog editor page.
sam. sept. 15 8:55:07AM
Stack Trace
java.lang.NullPointerException at sun.util.calendar.ZoneInfoFile.getZoneIDs(ZoneInfoFile.java:785) at sun.util.calendar.ZoneInfo.getAvailableIDs(ZoneInfo.java:535) at java.util.TimeZone.getAvailableIDs(TimeZone.java:516) at com.inductiveautomation.factorypmi.designer.projectproperties.ClientGeneralPropsPanel.initComponents(ClientGeneralPropsPanel.java:49) at com.inductiveautomation.factorypmi.designer.projectproperties.ClientGeneralPropsPanel.(ClientGeneralPropsPanel.java:40) at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) at java.lang.reflect.Constructor.newInstance(Constructor.java:532) at java.lang.Class.newInstance0(Class.java:372) at java.lang.Class.newInstance(Class.java:325) at com.inductiveautomation.ignition.designer.propertyeditor.PropertyEditorDialog.lazyInit(PropertyEditorDialog.java:190) at com.inductiveautomation.ignition.designer.gui.LazyFrame.open(LazyFrame.java:63) at com.inductiveautomation.ignition.designer.IgnitionDesigner.showProjectPropertyEditor(IgnitionDesigner.java:1105) at com.inductiveautomation.ignition.designer.navtree.ProjectPropsNode.onDoubleClick(ProjectPropsNode.java:36) at com.inductiveautomation.ignition.designer.navtree.NavTreePanel$MouseListener$1.run(NavTreePanel.java:556) at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226) at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:670) at java.awt.EventQueue.access$400(EventQueue.java:96) at java.awt.EventQueue$2.run(EventQueue.java:631) at java.awt.EventQueue$2.run(EventQueue.java:629) at java.security.AccessController.doPrivileged(Native Method) at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105) at java.awt.EventQueue.dispatchEvent(EventQueue.java:640) at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275) at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200) at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190) at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185) at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177) at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Could be this bug: bugs.sun.com/view_bug.do?bug_id=6529213

This bug appeared without changing the version of java.
You advise me how to solve the problem?
Thanks :scratch:

Do what the link says: make sure permissions on {YOUR_JRE_LOCATION}/jre/lib/zi/ZoneInfoMappings is 0022.

Thanks but the permissions are already set to 644 for this file :

-rw-r–r-- 1 root root 14659 sept. 11 12:10 ZoneInfoMappings

Path : /usr/lib/jvm/java-7-openjdk-common/jre/lib/zi

I’m on Ubuntu 12.04 64 bits (Client and Designer). I think that there was a Java update last week. Do you think it may be linked ?

The server on which the Gateway is installed is on Windows 2008 Server R2.

When I launch a designer on the server directly, I can see the missing menu. It seems to be a problem permission on clients machines no ?

Yeah, it sounds like an issue on that client machine. I would guess that the Java update is related to the problem too…

When I launch a designer or the application on a Windows client, I have the missing menu.

Moreover, timezones are ok on the windows client. They are not ok on client on which the menu is missing.

Can you uninstall/reinstall Java on the linux machine that has the problem?

This has been done but the menu is still missing.
I had JRE7, JRE6 and icedTea installed. I removed all of them then reinstalled java 6 and icedTea (for Java Web Start).

But it did not do the trick.

Edit : I’ve tried on multiple several computers. The menu is not missing on computers running under Windows. It seems to be a Linux problem (maybe only Ubuntu).

The last ubuntu 12.04 update fixes the problem.
Thank you.