Mobile client on Linux Server

Hi all,

I have some trouble with getting the mobile client up and running on a gateway running on a Linux Server.

I have already followed this post from the knowledge base.

I have also been in contact with the support of IA. They tried and fixed it remotely, but wasn’t able to fix the problem.
Eventually we found that I was able to launch the mobile client if I was connected to the Linux server through the MobaXterm client first, which is very strange.
What we saw was that when I was logged in to the Linux server through SSH using the MobaXterm client using an my laptop or desktop computer, both running windows 10, I could go and start the a mobile client both through the web browser on my computer or my phone.
When the mobile client was running and I closed the session in MobaXterm the mobile client would terminate with the error: EOF
If I try to launch a mobile client without being logged in to the Linux server through SSH using the MobaXterm client then I will get the error: “Java.Lang.Exception: Timeout waiting for the new VM.”
Initially it was believed that MobaXterm is somehow opening some sockets on the server or doing something else that the mobile client is then using. This was what the support of IA believes.
I believe that it might be something about the Xserver that the MobaXterm client is starting that interferes with the mobile client somehow.

Has anybody made Mobile Clients work on a Linux Server? If yes, what did you do to make it work?

My setup has the following specs:

  • Linux version 4.4.0-98-generic (buildd@lcy01-03) (gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.4) )


  • Java version “1.8.0_161”
  • Java™ SE Runtime Environment (build 1.8.0_161-b12)
  • Java HotSpot™ 64-Bit Server VM (build 25.161-b12, mixed mode)


  • 7.9.9 (b2018081621)