Mobile Module Stopped Working on One Device Only

I have a customer that has been running the mobile module successfully for several months now on one Android phone and two iOS devices. This morning, one of the iOS devices (iPhone 3Gs) displayed an error and wouldn’t load. The Android phone still works, and I can get in with my iPhone 4s. The customer updated his phone to the newest iOS version, and tried going back in through Safari (he had bookmarked the link) and still gets the same error. Anyone have an experience like this? Any ideas of what I would need to reset or clear to get his phone working again? Thanks!


Have you tried to Clear History and Clear Cookies and Data? These can both be found by navigating on your iOS device to settings>safari.


I had our customer try that a few minutes ago, and he reported that it still will not load on that phone. Any other suggestions, or are there any logs I should pull? Thanks.


What is the error that the customer is getting?

instead of using the bookmark he has in his browser, try to retype the address in the browser. Also, compare that bookmarked address to the address that is on the gateway homepage.

OK, attached is a screen cap of the error he is seeing. I’ve verified that everything is working on multiple devices, but isn’t on this particular phone. I’ve had him Clear History and Clear Cookies and Data a few times now. iOS on the phone is (I believe) 5.1.1 and Ignition is version 7.2.4

The error message your getting is a general error message. It just means that something went wrong, and nothing more specific than that. As of right now, I’m not convinced that the problem lies entirely with the phone. Are there any errors in the gateway console? Try connecting again and see if any errors occur. If there are errors, copy and paste them here so we can take a look at them.

OK, here’s the latest. Last night, he was playing with the settings on his phone. He set Safari to Always accept cookies, and now the phone is able to connect. Does that make any sense? I don’t know if there were any other setting changed, but the end result is that this particular phone is able to connect again. Thanks.

Yes, that does make sense, always accept cookies should be enabled. Dont know how that got skipped in the troubleshooting. :scratch:


I’m not sure either. I’ll let him know that was the fix, and that he’s good to go. Thanks!


Just glad to hear that worked and he is able to use his iPhone the way it was intended, with Ignition! :thumb_left: