Mobile module woes

I am having trouble getting the mobile module to work on an android handset,

In the browser it just saysweb page not avaliable.

The mobile module is only in trial - we havent purchased it yet as I want to show management before I ask them to fork out for it.

I have connected the phone to the wireless access point at work and can get on the internet with the phone but it will not resolve this page. I have tried to find if anyone else has the same problem in the forum and I cannot tell if its the same issue or not.

My web access gateway does not say localhost in the web-url it has the correct server name. I have additionally tried typing the server address in my phones browser. I have also tried using Dolphin browser as read somewhere else in the forum but none worked. I have a Nexus1 with Android 2.3 but I tried a collegues Samsung Galaxy S on 2.2 with the same result.

Just for your information in our case its: ccfign01:8080/main/system/mobile

(port 8080 is the port that is configured on the ignition gateway and I have also tried using the IP address instead of the server name but with the same result)

Additionally I set my notebook up to get on via wifi, and then navigated to the same mobile launching page and it worked just fine so now I am really confused.

I tried to install the 7.3 beta on a hyper-v VM, imported my mobile application - same result. Notebook can get to the mobile landing page, neither android phone could.

I dont have an iphone or ipad to play with so I am not sure if this is an android related problem but the two phones were on different UI’s (samsung was stock Touchwiz, mine is vanilla android and then I flashed cyaongen and lastly miui to make sure that it wasnt a rom thing)

Lastly I downloaded the trial at home, setup the server on my home PC and could get to th emobile landing page on my PC, but could not connect via wifi.

I have set the application to be mobile enables, fit to screen I have set the permissions, made the application autologin (for testing) I am stuck on what else to try now.

What is the IP address and subnet mask of the Android phone? You should be able to get this by settings->Wireless & networks->Wi-fi (or something like that depending on your version of Android).

What is the IP address of the gateway?

Do the Androids have a cell/wireless data plan? If so, you’ll want to disable this for troubleshooting.

Yeah I am pretty fine with networking. I disabled the APN for troubleshooting, I checked the IP ranges and I even set a static IP on the phone.

My server is, my phone was - both have a subnet mask of and the gateway is

I have verified that I am on the network, I can even use smb file sharing clients on my phone to get to network shares on the server - meaning that on the server I have a network directory for ignition update files etc and I can loginto that using my domain login credentials using my phone and download the file.

Its just the IIS server that I cant seem to see - and I can see it from my laptop. I thought it was my browser so I downloaded two more, opera mini and dolphin HD. Both are the same result

I then thought maybe the rom I was using was no good, so I flashed back to stock vanilla android, then tried cyanogen and miui - same problem (all have slightly different network drivers to vanilla although I think miui and cyanogen might share them since recently)

Then I tried a completley unmodified samsung galaxy s - same problem, could get on the network - gain internet access through the corporate router, see computers but the IIS was unreachable

Then I logged onto the console of my ignition server, the weirdest thing is that it doesnt even look like the console can see the phones making a request.

When I looked at the mobile landing from my desktop it saw it, when I used my notebook on wifi using the same access point as my phone it saw the request but from my phone - nothing.

I am not sure what to say now I have runout of ideas to try. I never thought I would say this but I wish I had an iphone laying around to try - I think my daughter has an ipod touch 3g which might work so maybe I will bring that in next week and give it a go to see if that works. I am still not sure what that would prove though.

Any Ideas?

You can get an app called Ping & DNS for your Android phone. It’s free, and you can use it to try to ping the server that is running the Ignition gateway. If it can’t ping, then you know the phone definitely can’t reach the gateway. Another option is to download a standard Tomcat server and install on your local box. It’s a really easy install on Windows. Then navigate on your phone to :8080 and see if you can see the Tomcat home page. At the very least, these steps will give a better idea of where the problem lies.

Good idea, i will try that next week at work - thanks

Finally got my phone connected.

I could ping the server, I could get onto my own PC’s tomcat server - I even tried reverting the port of the server to 8088 from 8080 where I had it.

Turns out there might still be something wrong with the ignition gateway though, it only worked when I went into my browser and changed the user agent to iphone 4. It worked as iphone 3 and ipad as well.

When my phone identified itself as an android device the gateway said there was no page avaliable for it and just denied access.

Ignition team: if you have anything you want me to do to futher diagnose this problem then let me know but it seems there is an issue with the gateway identifying the phone (not just mine) as a valid android browser.

This is bizarre. The gateway homepage does do browser detection, but you’re either going to get the mobile page or the normal pc-based home page, not some sort of denial. Also, if you navigate directly to /main/system/mobile the user-agent checking is bypassed entirely.

Also, we test with android devices in-house routinely and they work fine. Can you show me exactly what this “denied” page looks like? Maybe something is interfering between the phone and they gateway?