Modbus adressing Akytec

Hi Guys,

Im having trouble adressing the values framed in red in the picture, any ideas? :slight_smile:
This is the manual, modbus stuff is around page 29

I tried this:

Those are 32-bit values in adjacent registers. That would be the HRF address format. You may or may not need to use the “Swap Words” advanced driver setting. Have you read this page in the manual?


Yes i did read it, and i tried inserting this to no avail:

On page 39 of that manual, it says the default node address is 1. Ignition’s driver defaults to zero if not specified. Try [A1]1.HRF4000.

Thanks for trying to help, its appreciated!

I did both [A1]1.HRF4000 and [A1]1.HRF4064 and it still makes an error


Don't read 4064 with HRF--the table says that one is 16-bit. Only use HRF on the 32-bit floating point registers. Also, these addresses are all "zero-based" instead of "one-based". Ignition's driver defaults to one-based. You probably need to change that in the device settings.

I also noticed in the manual that the log file, if you need it, must be read with function code 20. Ignition's native driver cannot do this. If you need it, you will need something else, like my alternate driver:

Hi again,

Neither seems to be working, however i did notice this in the gateway, something is definitely off…

So this, apparently the adresses are still incorrect

Did you set the device to zero-based addressing?

That definitely did something, now its getting some sort of data through, although im not sure what to make of it

Almost certainly need to also change the “swap words” setting in the driver.

And there we are, it works!

Thank you very much, is there anything i can do to repay you?

Pay it forward here on the forum. (:

Hi, I have the same problem with some feeders:

This is part of the documentation:

in this case i try to map the hopper 1, this is the way I try to map it: [TWIN2_PC]1.HRF02003 and this is other the way I'm trying to map it too [TWIN2_PC]1.HRF02003

Get rid of the leading zeroes in your addresses and see if that helps.

Same error: Received response with ExceptionCode: 0x02 (IllegalDataAddress).

Ok, that’s the device telling you that you have the wrong address.

How did you arrive at 1.HRF2003 given the documentation screenshot you posted?

Try 1.HRF110 or 1.HRF40110 instead?

1 Like

If they really are 32-bit floats, then it must be Enron protocol, and therefore not going to work.

But the "multiplier" column makes me think they are really integers that use scaling.

Try [TWIN2_PC]1.HR110, where 0-10,000 yields 0.00-100.00%.

1 Like