Modbus coil write error

I am trying to turn on an output on a Automation Direct Field I/O. I am connected and have created a tag and the tag seems to be good but when I write to it I get an error that reads

“[AWT-EventQueue-2] ERROR com.inductiveautomation.ignition.designer.sqltags.util.TagUtilities$WriteListener - Error writing to C1.Value:
Bad; unspecified.”

I can read inputs from a pressure sensor on IR1 just fine.

The layout is analog input in slot 1
Digital output in slot 2

I have also tried creating a address in the device connection screen.

Prefix = DO
Start = 1
End = 8
Step = unchecked
Unit ID = 0
Modbud Type = Coil
Modbus Address = 000001

I can access the tags with no error in OPC browser but I get the same error when I try to write to it.

Any ideas?

You might find a more detailed error in the gateway logs, but either way it’s likely going to be a configuration issue on the device side.

I’ve seen similar cryptic error messages. A couple of things to check.

  1. Verify the tag setup has read/write permissions. (Error usually indicates this)
  2. If you are doing so from the designer, ensure you are in Read/Write Comm mode. (Error usually indicates this)
  3. Restart the designer to see if that clears it up.
  4. Restart the gateway service to see if that clears it up.

If none of that helps, then I would agree with Kevin that the Automation Direct device isn’t permitting writing for some reason.

Another thing to check is to see if your device address is 1 or 0 based. Try something in the range (you indicated 1-8, but it may be 0-7), like 4. If it works, you may be out of range for the device. If you find 1-8 is actually 0-7, update the device configuration on the gateway to offset appropriately.

The issue was the watchdog timer being to short and faulting out before really having a chance to communicate.