Modbus Communication with SEL RTAC

We have SEL RTAC 3555 we are trying to communicate over the Modbus protocol.
Below is error we are facing.

Appreciate your help to resolve this issue.

We use Modsim32 and Modscan to test the modbus communication between RTAC and Ignition machine and its working good.

Below are the packets capture using wire shark

Server sends TCP syn to RTAC
RTAC response with TCP syn ack acknowledging connection

Server sends acknowledgement back to RTAC to complete the 3 way handshake.

RTAC sends Fin to the Server to close the connection

Have you created any OPC tags for this device yet?

We are not able to browser the tag in OPC client.

We discussed this with SEL they have raise a question
"Is the Ignition system using TLS connection encryption? "

Modbus protocol doesn't offer browsing.

You need to manually create OPC tags with OPC Item Paths that use the address syntax described in the user manual: Modbus Addressing - Ignition User Manual 8.1 - Ignition Documentation

I don't see how this is relevant to Modbus.

I tried creating OPC Tag, but no luck on that.

The device status in device connections created to communicate with RTAC keep on switching from Connection to Connected and Disconnected, I would say it show connected for few sec.

Please show what you tried. If you have no properly configured OPC tags, the channel is likely to time out (many, many devices time out after ten seconds).

Try [PSCADA]1.HR2 as the address instead. These other software often default to unit/slave ID 1 instead of 0, which is the default in Ignition.

If you can also share some actual Wireshark captures of both the other software and of Ignition that would help as well.

1 Like

Thanks for sharing that @Kevin.Herron its work.

Appreciate you support and help @Kevin.Herron and @pturmel

Have a good day!