Modbus - Connection problems when editing addresses

I sometimes loose connections with my Modbus Device sometimes when I make address changes in the device. The only way I can get it to reconnect is to Stop the gateway service and restart. Here is the error I am getting in the event viewer.

Also… I will be posting some other questions about Modbus in the Designer Help section.


Event ViewerMessage [Shark100] Connect Error: IOException while connecting.

Logger com.inductiveautomation.xopc.drivers.modbus.ModbusDriver

Time 6/15/10 5:11:14 PM Level ERROR Thread http-8088-5
com.inductiveautomation.ignition.gateway.web.pages.config.systemconsole.LogViewer$SerializableLoggingEvent$ClonedThrowable: Connection refused: no further information Method) Source)
com.inductiveautomation.xopc.driver.api.AbstractEthernetDriver$ Source)

When you state “…when I make address changes in the device” do you mean adding additional mapped addresses in Ignition?

Which version of Ignition are you running?

When mapped addresses are added, the driver restarts and a new TCP connection is established. Depending on the version of Igintion you are running, there is an issue that in some cases the TCP connection is not closed correctly. As a result a new TCP connection request can be refused by the device upon restart. This is what the error message indicates but I don’t have enough information to be certain.

Release 7.1.2 that is due out shortly that resolves this issue and I recommend first upgrading. If it is still an issue after upgrading, please post another request.


Yes Tom… thats what I ment.

I am running 7.1.1

7.1.2 has been released.

I upgraded to 7.1.2 and had a small problem with Modbus. I had one Modbus device configured, but I had the modbus device disabled. After the update, I decided to try out the device, so I enabled the device and it would never connect. I tried reseting the Modbus Driver, Reseting the Ignition Service, I even renamed the device and it still would not connect. I rebooted the computer and still same result. I check the Ignition Console and “ModbusDriver - [Shark100test] Opening TCP connectioin” just keep on repeting. I rechecked all the configs and everythnig was correct. I then decided just to delete the device and start the device from new. That worked. Since then I have had no connection issues. I can make changes in the name… the address… ect and it always stays connected. I was just trying to find out when a configured device would not connect after the upgrade to 7.1.2?

Thank you for passing along your findings.

Yes, there is a problem when upgrading from 7.1.1 to 7.1.2. The port number doesn’t get set correctly. It will be solved in the next release but in the mean time you can select advanced properties, change the port to 501, save it, then go back in and change the port back to 502.

I am fine now… I just wanted you to be aware of the problem.