Modbus issue.... ignition settings or hardware?

Hi everyone,

Here is my problem (pulling my hair out for a few days now). I have a solar inverter device (modbus ID 6) that has a modbus output via 2wire RS485 that is routed to a Modbus Gateway Device (2 Ports and Ethernet).

I have created the device connection (Vlinx Modbus Gateway) in Ignition and it is connected fine with no issues. I have created tags and all of them have “Bad” quality.

The configuration for Vlinx gateway to the Solar Inverter has the correct settings and I have given priority to device “6” for the time being.

I have tried to manually reference the data source [pvinverter]6.HR2 and integer type.
device connection > Modbus ID > 40002 int16 holding register

I have also tried using ignition mapping.
PV > 40002 - 40002 > no stack > 6 > 002

It feels like I have literally tried everything. VLinx is indicating good connection to Solar Inverter as well.

Could a firmware update in Vlimx maybe fix this? Was originally run in an XP machine years ago.

Thanks

Stick ModPoll on it and see if you can read the registers.

In Ignition it is normal to have to try reverse word order and/or one based addressing, this differs based on the Modbus end device.

I standardise on Moxa MB3170 for RTU to TCP conversion.