Modbus TCP connection problem

Hi everyone,

Probably this is the topic that has already been discussed. I am using Ignition version 7.9.4 to connect to Panasonic FP0H PLCs using Modbus TCP. I am still in the initial stage of device connection. However, the connection status keeps changing from connected to disconnected time to time, and I’m worried if this continues, I might have bad tagging problems. I have searched and tried what other people has mentioned in these forums but they don’t work. I have tried increasing the communication timeout from “2000” up to “30000” but the problem still remains. I also have tried decreasing max holding registers and max input registers to save the scan time but doesn’t work.

I have attached the communication settings for my PLC (hopefully it can be viewed)
I have changed the TCP ULP timeout time to 20*100ms to match my Ignition setting but the problem persists.
Appreciate any help from you guys.
Thanks.

If you haven’t subscribed to any tags yet this is common with Modbus devices.

Thank you for your reply.
I also have a problem with subscribing the tags, as I am getting null values all along.
I used holding register 40001-40006 in my PLC, and retrieve the value from Ignition with " [Modbus]HR1 ". Since my stored value in the register is “unsigned integer”, I also tried " [Modbus]HRUS1 " but they both do not work.
I have attached part of my error log since the log file I have is too big to attach.
Hope you could help. Thanks.

You may need to specify a particular unit ID (may be listed as a ‘slave ID’ or something similar in your device configuration). This can be pre-pended to the register path, ie: [Modbus]2.HR1 or similar.

How many connections your Panasonic FP0H support? Is Ignition the only thing that is connecting to the PLC?