Modbus TCP driver

I’ve been trying to use the Modbus TCP driver to communicate with a custom made Modbus device that implements the python modbus-tk module. I am able to communicate (both read and write registers) with is using any modbus master test software. However, when I try to do it from Ignition I’m able to write to the device’s registers but I can’t read them. I always get this message on the quick client:

Read completed. [Ignition OPC-UA Server]ns=1;s=[aaaaaa]1.a0
Status: Bad
Value: null
Quality: [Bad] Bad; unspecified.
Timestamp: 01-01-1601 0:00:00 GMT

I’ve also tried to run a test Modbus server ( Although it works perfectly with my modbus test client software it happens exactly the same in Ignition, I can write to the server but I can’t read from it. I always get the same error.

I’ve already tried different advanced configurations on the device page on Ignition.

Any idea on how can I solve this problem?

It’s at this stage I usually reach for Wireshark to have a look at the actual data being sent and received. If you can do this and post the comms traffic it will be easier to diagnose.

+1 for Wireshark.

It would also be useful to know what you’ve mapped a0 to. Usually it’s easier to troubleshoot without the mappings set up - just create a tag in the designer that addresses [aaaaaa]1.HR1 for example.

I formated my laptop and re-instaled windows and ignition… It solved the problem.