Modbus TCP issue with Schneiders Harmony device

I am trying to configure a Harmony hub via modbus TCP and it look like its not working and I can’t figure out why. I tested it with modbus doctor and I do get some values back.

But in ignition I got this :

This is what the manual say about addressing , I am reading a type 4 device which is a temperature sensor on input 1. (10+33*1 = 43 so I should have a value of 4 returned since I have a type 4 device)

I tried many register and many ways but still nothing :frowning:

I did set the driver as modbus tcp , port 502 and the IP and the right IP .

Am I doing smt wrong ? :face_with_monocle:


Go to advanced section of device properties, try 1 based setting and reverse word order

The temperature is a single word at +6 beyond that, and the test app shows slave # 248. Try:


And note its unit is 0.01°C.

I thought about it so I tried HR248.xx but never tried 248.HR44 !! damn I really appreciate both of you for your help !! have a great day :call_me_hand: