Modbus tcp tags not working

Im having an issue with some Modbus tcp tags im getting from a compressor PLC. I have 3 identical compressors. When I first mapped the addresses of the first compressor they came over just fine but after doing the other 2 compressors a little different I deleted the tags from the first compressor and tried to re- map them the same way I did the last 2. The issue is the first compressor tags show up with a question mark and an uncertain initial value error. The device is connected and there are no errors other than when I add the tags from that compressor they all have a (?) as the value. The other 2 compressor tags are fine. I have tried to delete and re add the tags, delete and re-do the device connection, but nothing seems to work. Any Help would be much appreciated.
Ignition version 8

Can you share a screenshot of the mapping for the problematic connection?

Did you delete all the tags you created in Ignition Tag Browser and re-drag them in from the OPC Browser after you changed the mapping?