Module Config Title Issue

I am having an issue with my settings title on the IConfig tab where It doesn’t seem to be finding the title definition and I am struggling to figure out where the issue lies.

image

I have been trying to make sure I had my casing consistent everywhere so that I was referencing the right objects but can’t seem to fix my title. It takes me to the right page, just won’t say “Settings” for everything I have tried.

Here is my hook:

public static final IConfigTab NEO4J_CONFIG_ENTRY = DefaultConfigTab.builder()
            .category(CONFIG_CATEGORY)
            .name("neo4j")
            .i18n("Neo4J.nav.settings.title")
            .page(Neo4JSettingsPage.class)
            .terms("Neo4J settings")
            .build();

The settings page:

public static final Pair<String, String> MENU_LOCATION =
        Pair.of(GatewayHook.CONFIG_CATEGORY.getName(), "neo4j");

    public Neo4JSettingsPage(final IConfigPage configPage) {
        super(configPage, null, new LenientResourceModel("Neo4J.nav.settings.panelTitle"),
            ((IgnitionWebApp) Application.get()).getContext().getPersistenceInterface().find(Neo4JSettingsRecord.META, 0L)
        );
    }

and my Neo4J.properties file under the resources folder

nav.header=Neo4J
nav.settings.title=Settings
nav.settings.panelTitle=Neo4J Settings
nav.connections.title=Connections

Neo4JSettingsRecord.Category.Configuration=Configuration
Neo4JSettingsRecord.Category.Security=Security

Any ideas what I am missing here? If I need to provide any other snippets just let me know.

Are you restarting the gateway when making these changes?

I didnt restart the gateway as it was automatically updating the Header, but I can see if that fixes the title.

EDIT: Looks like that fixed it! Weird that it will automatically update the header and not the title? Any specific reasoning for that?

I am struggling to understand when a module update requires a gateway restart or not.

Well… when dealing with BundleUtil or properties files just assume you have to restart.

3 Likes

I didn’t want to “like” that, but it’s the right answer. ):

1 Like