Module Creation problem in 7.9.4 beta 1

Hello everyone,

Since the update to the new version 7.9.4. I have a problem creating a .modl file from a project ( (79.1 KB)
) I got from an employer of the inductive automation. However, when he creates an .modl file, it properly runs when installing. When I reproduce an .modl file with Eclipse Neon 3 with the exact same code, it receive an error message:

What I did:

  1. I deleted the .modl file within the folder ExpressionFunctions-build\target.
  2. I imported the maven project to Eclipse
  3. I cleaned each project
  4. I right clicked on “PaulWurthExpressionFunctions” (the main project) → run as → Maven build… → package

Actually as described here and it worked until now. The strange thing is, within Eclipse, no errors occure:

What I tried in addition to solve the problem:

  1. Deleted the ignition files within .m2 folder and let Maven download the files again.
  2. Created the .modl file on another Eclipse Version on a different PC with the same procedures.
  3. (EDIT): I used the latest ignition-maven-plugin 1.0.12. The code I got used the 1.0.8.

The problem persist and I need some help please.

Thank you very much in advance.

Can you attach the module that gets built when you run it?

What version of Java do you have installed?

Sorry I forgot to attach my .modl file. Here it is:

Expression-Functions-unsigned_Mine.modl (11.6 KB)

I am using the latest version of Java and Eclipse. Oh yeah I forgot to mention that I even tried to create the module using the recently released Eclipse Aqua! Still same problem…

Can you launch with the Java console enabled and get the full output of the console leading up to that error?

Sure if you tell me the command shell commands I need to use to run a .modl file :wink:

Because the standard java -jar is not working for .modl files.

Nevermind, the real problem is when you build it duplicate files are getting put into the jars:

Caused by: duplicate entry: META-INF/maven/com.paulwurth.expressionfunctions/ExpressionFunctions-designer/
	at java.util.jar.JarOutputStream.putNextEntry(
	at com.inductiveautomation.ignition.client.launch.steps.DownloadJarsStep.downloadJar(
	... 8 more

I don’t know what’s different about your build environment that causes this though.

Maybe try running the ‘clean’ Maven goal before you build the module.

As mentioned, I already tried all the cleaning stuff. Nothing of all the cleans helped to solve that problem. I even tried to delete the entries in the .m2 folder. I used a new installed Eclipse NEON 3 on another PC and the newly released Aqua one.

Hence, the project and environment could not be more “fresh”! I could bet the problem lies on what maven downloads with all the dynamic versions option. I already told Travis, things like ${ignition-sdk-version} this should be avoided because it only produce unnecessary problems with versions. The version should be static, then Maven could at least check if the correct “new” version even exist in the specified path instead of using the latest one…

So what I think is, that you may have other versions on your local .m2 folder than Maven downloaded? That’s why I send Travis a mail with the content of my .m2 folder today to check if they are the same.

However, if you are sure, that this can’t be the problem, please give me another hint than cleaning.

Thank you.

Ant for the win!
Sorry, couldn’t help myself.

1 Like

Try building from the command line with Eclipse closed, this may just be Eclipse interfering:

Hello Kevin,

I did as you wanted and tried it in the command shell with Eclipse closed, but the result was the same. In addition, Travis Cox sent me his IntelliJ project ( (147.0 KB)
) and asked me to try it with IntelliJ IDE Trial version.

This super IDE does not find the plugin com.inductiveautomation.ingnitionsdk:ignition-maven-plugin:1.0.8. The version 1.0.12 is fine…

In addition, the IDE can’t find the following Maven dependencies:

  • com.inductiveautomation.ingnitionsdk:ignition-common:pom:7.9.0
  • com.inductiveautomation.ingnitionsdk:vision-designer:pom:7.9.0
  • ch.qos.logback-classic:1.1.7
  • net.sf.barcode4j:barcode4j:2.1

Do you know what the problem might be?

P.s. An option would be, that you send me the missing dependencies? (You should have them in your .m2 folder).

P.s. Using IntelliJ for ever is not an option even if it works later on, because the trial version is only for 30 days! Hence, even if we get it to run under it, the problem must be fixed using Eclipse afterwards!

Hello everyone,

The problem was as expected, that Maven could not load the newest dependencies from inductive automation repository. After Travis Cox sent me the content of his .m2 folder, the problem was solved and I could again create a .modl file with Eclipse.

I hope this help others with who might have the same problem than I had.

Pfeiffer Alain