More issues with Emulate connectivity

I know this is not the first time this topic has come up, but I cannot get Ignition device connectivity to an Emulate slot. I have done this successfully on other machines, but on this VM I cannot get out of ReconnectWait status. Does anybody see anything in the attached config that is wrong? I replaced “localhost” with the IP address in the Hostname and it doesn’t fix it. OPC Quick Client also does not see the device.

You need to use the OPC-COM driver and connect to the OPC topic you setup in RSLinx. Have a read.

1 Like

Also, you might be able to use FactoryTalk Linx and make an OPC-UA connection since that is a OPC-UA server. I have not tried it, but maybe someone on the forums has.

Not necessarily, see this post, Connecting to Allen Bradley simulated plc.

@pdixon saw that post, he was the last to respond. I’m not sure why it’s not working for you.

Well, this is news to me. Just tried it, worked. Sorry OP, I’ve got nothing…I’ll see myself out.

1 Like

I just noticed today @Travis.Cox made a L5K parser, I think it’s been out for a while though.
Download here:

Not a fix to your issue necessarily, but a way to test nonetheless.

You can also dump your Logix project into my Ethernet/IP module if you don’t need emulation of the ladder logic.

Thanks Phil, but I need emulation; I need the logic to run and operate

For an example, this is another VM that I have. Everything works. I don’t see any difference between the 2 VMs or my configuration.

This shows the device configuration for SheetTest, which I am using to connect to a slot in Emulate. I am using Flintium objects configured for the SheetTest OPC device

This shows that I successfully connect

This shows what it looks like in runtime. My Ignition application is able to connect the Flintium object and faceplate to the running logic in Logix.

I am now trying to do the same thing in another Win10 VM. I cannot get the device to connect to my Emulate slot.

Ah, more important info. If you have one VM working, and the other isn’t, that’s obvious to me that there is something different between the two of them. Screenshots really aren’t going to help much.

We narrowed it down. We setup trace level logging and found a connection refused:

io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: no further information: /192.168.148.4:44818
java.net.ConnectException: Connection refused: no further information

I assume this is a security level thing in Linx, but not sure where

Port 44818 is the Ethernet/IP port, not an OPC/UA port. Are you using the Logix driver (Ethernet/IP) or are you creating a separate OPC/UA connection?

If the former, have you told RSLinx to bind the local Ethernet/IP port?

Logix driver. It is a connection refused issue, which implies security (see above). I have never had to bind an ethernet port in Lix to make it work; other VMs work without having to do anything special in Linx. The Linx Gateway configuration (see screenshot above) looks correct

Can’t you just use the other working VM?

No. The whole point is to get this working on the VM with the Rockwell licenses that are authorized on this VM