Moxa Mgate MB3180 troubleshooting questions

I have finally acquired a moxa to test if I can use it to convert serial to ethernet for ignition
Im hoping we can get 1 to work as a proof of concept , because then I will be allowed to get 2 more for other projects

the moxa is an Mgate MB3180,
the PLC is an FP7 Panasonic ,
I am using the modbus TCP driver,
I am using RS 232

Ignition is saying that the moxa is connected but using HR1 gives me a bad timeout

I tried checking the monitor on the moxa and this is what it shows me , my interpretation of this is that ignition is sending to the moxa just fine but the plc doesnt respond? thats what i got out of that. is this correct?

also here is the settings in the manual beside the settings in the moxa manager , they look like they match to me , so I have no idea what it is

any ideas what I am missing? , is there something else im supposed to do on a moxa?

Try unit/slave ID 1 instead of 0.

thats like this right? it still says bad

Yeah, make sure it's sending 1 on the Moxa side now too.

If it still doesn't work then I don't know, maybe you don't have the serial settings or the PLC configured right. I don't have any experience with that PLC.

Try reverse word order/zero based addressing in the ignition driver advanced settings.