MQTT Engine tag names/folders clashing

Can someone help me resolve this Ignition MQTT issue. I am reading/writing tags from similar devices. To keep my tag structure consistent, I labelled one device PLCA and the other PLCB. I can read from both folders without any problem. However, when I am writing, I can only write to one of the other folder tags.
Initially I thought it was my tag access. I then thought it might be tag write permissions in MQTT Engine. Then I tried recreating the tags in the MQTT device. I changed the folder name for PLCA to PLA and then writes started to work but when I tried writing tags with PLCB, it failed. I then changed PLCB to PLC2; I was able to write with tags from PLC2 but not tags from PLA. It is as if there is some tags clashing but I cannot determine which tags/folders/device that is causing the issue.

Hi Ngonidzashe

It would be best to contact support so an engineer can remote in and see what the issue is. You can contact support at Support Home Page | Inductive Automation