MQTT Engine to Mosquitto

I’m having trouble subscribing to topics on a Mosquitto broker. Node Red is publishing to this broker without issues and it seems like the Engine is connected, yet tags don’t work.

See screenshots below:

image

This was working, and now failed.

The Mosquitto cofig is as basic as it can get. Only the listener specified and no ACL.

@wes0johnson, @kcollins1 , you what else can I look at?

I don’t see any errors in your logs. Are values being published to [any of those] topics regularly? If the topics were not published with retain=true, they might not immediately populate tags upon connection/subscription (and instead when a data value is published).

Retain is set on the tags and the temperature tags are published every 10s.

What I find strange is that the Engine module can subscribe to the tags when I use the Distributor. All topics remain exactly the same (I just make Node Red publish to the Distributor)

Interesting… Can you review the thread here for insights?

It feels like some of the same troubles we saw there… :thinking:

I did. Disabled all default namespaces as I’m only using normal MQTT.

Also enabled TRACE on the CirrusClient logger, but that was too noisy for me spot anything. Set it down to DEBUG

Sorry, should have mentioned that.

Can you confirm your subscription configurations? It looks like you’re subscribing to:

  • Pool/#
  • Geyser/#
  • Electricity/#

And the topics you’re publishing to are discrete values (i.e. not JSON)? Therefore you have JSON Payload unchecked in your three custom namespace configurations?

2022-05-23 at 9.32 AM

Subscriptions are as you have it.

I don’t have access to the system right now, so can’t confirm the JSON payload option. The namespace config did not change between Mosquitto and Distributor, though, and works in Distributor.

Out of interest, is there an advantage over JSON payload parsing or not if I have control over the publishing? I can easily change the payloads to be JSON if they aren’t.

Sorry about the long break.

I changed the option not to parse as JSON, and the behaviour is the same: Distributor works, Mosquitto doesn’t.

I spotted this: