MQTT Transmission UDT metadata not updating MQTT Engine

We've created a UDT on a Ignition Edge Gateway running MQTT Transmission. This is successfully publishing to an MQTT broker and we are subscribing to the broker on the MQTT Engine side.

Any tag value changes on the Edge Node running MQTT Transmission will be updated on the MQTT Engine. We can add new tags or create new UDTs, hit refresh in the MQTT Transmission Control and can see the new tags populate on the MQTT Engine. BUT when we make a change to the metadata within the UDT for example, we don't see that change take effect on the MQTT Engine. For example, changing the Engineering Units or Deadband on the Edge Node, we see no update on that data on the MQTT Engine. We've tried deleting the tag on the Engine entirely to see it repopulate and still no UDT metadata change.

I'm assuming it's a setting or something we've missed?

If this is on 8.1.22 it may be a regression bug. Check your logs for errors like "Error processing edit for tag path" discussed towards the end of this thread (the top of the thread has to do with unrelated EAM issues and you can ignore it):