Multiselect rows in a Table from a script

How to do? I tried copying to (sic) but no go. is, as far as I know, read only. It's only there to reflect what data is selected, it doesn't dictate what is selected.
I'm not sure what you can do. Maybe selection.selectedRow is where it's at ?

It looks like it holds one value, so what should I put there?

Even when multiple rows are selected ? That's surprising, I would expect it to switch to array when multiple selection is enabled.

Here you can see that I have 3 rows selected in the bottom table (using Shift + click) and that the selectedRow and selectedColumn props only have one value :cry:

Indeed, the doc says it's the index of the first selected row. I have no idea how you could, if possible, script the selection of multiple rows...

No problem here on 8.1.31.

You wrote to and it showed up as selected in the table?

No, I'm addressing your post #5. You have multiple rows selected and they're not showing up in

There was a post a while back explaining why programmatically selecting rows would be problematic. I'll see if I can find it.

Ok see if you can find it... They are appearing in, I was referring to the fact that a single integer appears in the selectedRow property, if you look closely, there are 3 fields in

I will probably just use an embedded view with a checkbox to do multiselect and style the rows based on the checkbox value. I wish there was a native way to do a "Select All" action.

This is what I ended up doing for a project I'm working on. I also added a way to multi-select rows on a display without a keyboard by being able to click a row and then another row and the rows inbetween and inclusive would be checked. It worked out pretty well.

You have to add the row number to your dataset which is so-so.. otherwise the checkbox won't be able to know what to check in your table. It's very awkward as you can't just turn on the checkbox, even if it's bi-dir bound to the incoming data from the table; the checkbox turns on but the table data doesn't change. You have to use messaging to change the value in your table dataset.

You don't actually need to pass in the row value, it is passed automatically into a table column's subview. See here

This is probably what I'll do..

Ohhh, that's much nicer! Cheers