My entire project is now missing from start up

Last friday I was working on a Ignition project that connects to a PLC inside of a VM. I finish my work, save everything, and exit the VM.

Now today, I tried reopening my project to show someone and it’s not there on the Ignition Home page when you start the gateway. When I go to configure, I see the project present. Opening the project in Designer doesn’t show any of the tags or windows, only the scripts. What happened and is there a way to fix this?

Is there anything in the logs?

Heres the wrapper.log.1 from Friday, the regular wrapper, and gcu log. 6’/7 was the last day I worked on everything. I mostly see error messages the same as I was seeing as I was designing, nothing out of the ordinary. Then today, 6/10, is when the issues happened. (353.8 KB)

I just had a coworker try to open up the project in a new gateway of the same Ignition version and it worked.

Also, trying to export from the project, despite only seeing scripts, I see the windows but they’re under a table called “Unknown” and there’s a few that are just blank.

Do you have any errors in the designer console? It sounds like it might be that one or more modules are failing to load in the designer, which would lead to things not showing up/‘Unknown’ status for various things.

This is all I see in the designer Console - 11:28:28.730 [AWT-EventQueue-2] WARN designer.main - Skipping module “Symbol Factory” because dependency “ModuleDependency[moduleId=“fpmi”]” is not installed.
11:28:30.642 [Designer-Startup] INFO designer.main - Downloading… [+0]
11:28:31.157 [Designer-Startup] INFO designer.main - Cleanup… [+515]
11:28:31.157 [Designer-Startup] INFO designer.main - Initializing UI… [+515]
11:28:31.248 [Designer-Startup] INFO ignition.TagManager.Gateway - Starting up polling tag manager, polling rate: 150 ms
11:28:32.666 [Designer-Startup] INFO designer.main - Starting module: Reporting [+2024]
11:28:32.693 [Designer-Startup] INFO reporting.Designer - Starting up Reporting Module. Mode: Trial
11:28:33.048 [Designer-Startup] INFO designer.main - Initializing Scripting… [+2406]
11:28:33.164 [Designer-Startup] INFO designer.main - Starting Tag System… [+2522]
11:28:33.165 [Designer-Startup] INFO designer.main - Initializing UI… [+2523]
11:28:33.356 [SQLTags-TreeLoader-1] INFO ignition.TagManager.Gateway - Starting tag polling.

Looks like the Vision module didn’t load. Can you confirm in your gateway that it’s running?

Gateway is running and I am able to do everything else in it. It does seem to be the Vision Module as I just tried to create a New project and again, no Windows dropdown in the designer.

Your designer is claiming Vision is not installed whatsoever. Can you confirm it’s installed and running on your gateway?

Oh I see now all my modules are faulted except for Symbol Factory which is loaded. I tried restarting the Vision Module but no effect, still faulted.

com.inductiveautomation.ignition.common.modules.ModuleLoadException: Unable to load hook class “com.inductiveautomation.factorypmi.gateway.FPMIGatewayHook” for module “fpmi”.
at com.inductiveautomation.ignition.gateway.modules.ModuleManagerImpl$LoadedModule.loadHook(
at com.inductiveautomation.ignition.gateway.modules.ModuleManagerImpl$LoadedModule.load(
at com.inductiveautomation.ignition.gateway.modules.ModuleManagerImpl.startupModule(
at com.inductiveautomation.ignition.gateway.modules.ModuleManagerImpl$
at com.inductiveautomation.ignition.gateway.modules.ModuleManagerImpl.executeModuleOperation(
at com.inductiveautomation.ignition.gateway.modules.ModuleManagerImpl.restartModuleInternal(
at com.inductiveautomation.ignition.gateway.modules.ModuleManagerImpl.restartModule(
at com.inductiveautomation.ignition.gateway.web.pages.config.ModulePage$RestartAction.execute(
at com.inductiveautomation.ignition.gateway.web.components.ConfirmationPanel$1.onClick(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.wicket.RequestListenerInterface.internalInvoke(
at org.apache.wicket.RequestListenerInterface.invoke(
at org.apache.wicket.core.request.handler.ListenerInterfaceRequestHandler.invokeListener(
at org.apache.wicket.core.request.handler.ListenerInterfaceRequestHandler.respond(
at org.apache.wicket.request.cycle.RequestCycle$HandlerExecutor.respond(
at org.apache.wicket.request.RequestHandlerStack.execute(
at org.apache.wicket.request.cycle.RequestCycle.execute(
at org.apache.wicket.request.cycle.RequestCycle.processRequest(
at org.apache.wicket.request.cycle.RequestCycle.processRequestAndDetach(
at org.apache.wicket.protocol.http.WicketFilter.processRequest(
at org.apache.wicket.protocol.http.WicketFilter.doFilter(
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(
at org.eclipse.jetty.servlet.ServletHandler.doHandle(
at org.eclipse.jetty.server.handler.ScopedHandler.handle(
at org.eclipse.jetty.server.session.SessionHandler.doHandle(
at org.eclipse.jetty.server.handler.ContextHandler.doHandle(
at org.eclipse.jetty.servlet.ServletHandler.doScope(
at org.eclipse.jetty.server.session.SessionHandler.doScope(
at org.eclipse.jetty.server.handler.ContextHandler.doScope(
at org.eclipse.jetty.server.handler.ScopedHandler.handle(
at org.eclipse.jetty.server.handler.HandlerList.handle(
at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
at org.eclipse.jetty.server.Server.handle(
at org.eclipse.jetty.server.HttpChannel.handle(
at org.eclipse.jetty.server.HttpConnection.onFillable(
at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.produceAndRun(
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(
at org.eclipse.jetty.util.thread.QueuedThreadPool$
at Source)
Caused by: java.lang.ClassNotFoundException: com.inductiveautomation.factorypmi.gateway.FPMIGatewayHook
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at com.inductiveautomation.ignition.gateway.modules.ModuleManagerImpl$LoadedModule.loadHook(
… 47 more

7.9.4 (b2017082911)
Oracle Corporation 1.8.0_121

This is the faulted error

Caused by: java.lang.ClassNotFoundException:

Do all of your module versions match with your gateway’s version? You may just need to call in to support, but something’s very wrong with your Vision module installation.

1 Like

Yup, it was Vision 9.9.4, the version for Ignition 7.9.4. The only thing I saw that was too far ahead was reporting module which was a .10, but even with that gone it didn’t do anything. Also uninstalling and reinstalling the correct versions did nothing because it kept saying the certificates expired in November 2018.

You could try upgrading your entire system to 7.9.11 (which is worth doing anyways)?

Try this: on the gateway, delete the data/jar-cache folder and restart the gateway. This could be related to a bug that happened in 7.9.4, and was fixed in 7.9.5.