MySQL database query oddity

@PGriffith I am running this query against a MySQL database:

select recipeData from Recipes where recipeId = “a2daf0ae-d35a-11ea-b3a8-069f50ec786e”

If I run this query from a 7.9 machine, unusual characters (unicode) get corrupted. If I run this same query on 8.0 against the same database the unusual characters come through correctly.

I’ve just spent 2 days pounding my head against the wall trying to figure out why my editor hasn’t been working when I stumbled on this.


FYI the field I am querying is a json data type.

Could be an issue with the JDBC driver in 7.9, could be an issue with default character encodings on the JVM, could be an issue with Jython…lots of variables. Try the gateway.database.selects logger on TRACE - you’ll obviously get a lot, but it should tell you what the query is returning before (most) of the parts of the system have a chance to mangle it.

I believe it is the JDBC. My old system has 5.1.23. The most recent one is 5.1.49. I want to install this alongside the existing one so if anything goes wrong I can swap back. However, I am getting an error that Classname must be unique since they are both com.mysql.jdbc.Driver

Any suggestions?

BTW: Do I use the jar file or the bin.jar?

From what I have read, they are identical so I guess it makes no difference.

You’ll have to replace the .jar file entirely (since, as you mentioned, the class has the same name) but it’s easy enough to switch it back as long as you have both versions.

Thank you for the help. Upgrading the JDBC was what it needed.