MySQL Not Updating

I am having troubles with changing a value in table to update MySQL. I run the following cellEdited script. It will look like it takes after I hit enter. However, after a few seconds it will change back and not update MySQL table to reflect the change I want. I don't get any errors and database table is correct. (test_locationn). I am trying to change Completed column and specific row from "N" to "Y". Thank you for any help.

Completed =, 'completed')

headers = system.dataset.getColumnHeaders(

query = "UPDATE test_locationn SET %s = ? WHERE Completed = ?" %(headers[event.column])
args = [event.newValue, Completed]

system.db.runPrepUpdate(query, args)

Try adding a refresh:

system.db.refresh(event.source, "data")

I have added that and it won't even look like it is trying to take. I just switches back to "N" Right Away

Does running the query directly in MySQL Workbench work? Perhaps there's a trigger you're unaware of that is setting the value back AFTER UPDATE or something.

I entered this into my MySQL and worked:
UPDATE test_locationn SET Completed = 'Y' Where ndx = 47;

It is updating in MySQL but still not on Ignition.

Your original query is WHERE completed not WHERE ndx

Did you try @JordanCClark's suggestion?

What does the binding on the table look like? Is polling set up or is it just static?