Need Help on OPC UA. It Gets Faulted

I just installed Ignition 8 web based trial application and I already set up connection to my CopactLogix PLC and it is connected now. But I have a problem to set up OPC UA.
It keeps showing me faulted in status in the last page. I have tried many addresses in endpoint and other fields but the same problem. My host IP is 192.168.0.1
I entered as:

  • Discovery URL: opc.tcp://localhost:62541/discovery
  • Endpoint URL: opc.tcp://localhost:62541
  • Endpoint Host Override:
  • Endpoint Security Mode: SignAndEncrypt
  • Endpoint Security Policy: Basic256Sha256

I turned off windows 7 firewall and Avast antivirus but what ever I enter as different port or IP address it does not pass and says:

UaException: status=Bad_ConnectionRejected, message=io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: no further information: /192.168.0.11:62541

Also It shows:

Few things…

Why are you trying to set up another loopback connection?

You said your IP is 192.168.0.1 but the error message says it’s connecting to 192.168.0.11.

The screenshot shows a different error message from connection “My_OPC4”, Bad_UserAccessDenied, which means it’s getting connected but you haven’t configured the right username and password.

So what’s the actual state of things? What are you trying to do?

I need to mention that the second one (Ignition OPC UA Server) is working properly. But I tried to set up another OPC with different name and it keeps getting faulted.

First I tried the IP 192.168.0.1 and it told me Access Dnied message as the attached photo.

Then I tried CPU IP address which is 192.168.0.11 and it told me
UaException: status=Bad_ConnectionRejected, message=io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: no further information: /192.168.0.11:62541

I assume you’re just trying to make another OPC UA connection to Ignition’s built-in OPC UA server for the sake of experimentation? If so, you need to provide a username and password when configuring it. By default it is opcuauser / password.

Yes. I am doing experiment and practice. :blush:
Where should I use these username and password to create another one?
I go to OPC Client-> OPC Connection → Create new OPC → OPC UA

Then, it asks me Endpoint URL. I will face the same problem when I enter aforesaid address and IP. Where is the username and password?

It’s on the screen you get to after this discovery flow. Try “localhost” instead of using your IP address.

1 Like

I saw the fields and now it is OK as I entered the same username and password you told me. Appreciate you.
Where can I change the username and password?

Config :arrow_forward:Security :arrow_forward:Users, Roles :arrow_forward: opcua-module :arrow_forward: More :arrow_forward:manage users:

1 Like