Network Gateway Scheduled Backup

I have been unable to get my gateway to backup to a network device. I have confirmed my filepath is correct, but it won’t back up to it.

Per another forum thread, I have also confirmed full user rights for the folder.

I have tried adding a shortcut to the network path on my desktop but ignition makes a new folder of the same name on my desktop and saves the back up there instead.

Any suggestions on a work around?

For a scheduled backup, your network device has to be accessible to the Ignition service, not the logged in user. This part of the manual should get you started.

Interesting. I misunderstood the location access mentioned in another thread then.
Thanks for the link!

Once that is setup, will the scheduled backup location I put on the gateway configuration be the “\fileserver\folder” (without quotations) still?

I’ll let a windows person answer that.

1 Like

If it’s a networked folder location that hasn’t been mapped to a drive letter, then it should be:

\\hostNameOrIP\path\to\your\folder

If the file server has been mapped to a drive letter then:

X:\path\to\your\folder

Per the linked document:

wrapper.share.1.location=\fileserver\folder

My meaning is I list the location on the gateway config as whatever location I assigned to wrapper.share.1.location, rather than putting, for instance, ‘wrapper.share.1.location’

Changing the .conf simply makes the remote folder accessible by ignition and then I access it the same way as I would any other folder?

For network locations one must use forward slashes!
//hostNameOrIP/path/to/your/folder

This hasn’t been my experience :confused:
Here’s an example path that’s stored in a configurable String tag on one of my gateways:

\\myclientsstorage\common~~isodoccontrol\Work Instructions and Key Points

That’s the same format you’d expect to paste into the address bar of windows explorer, which also works.

Could this be a regional difference?

Ah, I see the issue now.
I didn’t realize this path was being set inside the wrapper.conf, my mistake.

Adding:
wrapper.share.1.location=\CSI9\NetBackups
wrapper.share.1.target=Z:
wrapper.share.1.type=DISK

To the config file and setting my backup location as Z:\CSI9\NetBackups failed. I also tried \CSI9\NetBackups and that failed also.
Using windows file explorer I can navigate to the folder without any issues.

Did I enter the wrapper information incorrectly? (I am just noticing I had a single slash beforehand, I can try fixing that at some point if that was the issue. Just don’t want to shutdown and start up again right now)

wrapper.share.1.location=\\CSI9\NetBackups
Double slash!

Changed to double slash and tried again, still not backup on the network folder.

If I navigate to \CSI9\NetBackups I have no issues whatsoever, but even with:

wrapper.share.1.location=\CSI9\NetBackups
wrapper.share.1.target=Z:
wrapper.share.1.type=DISK

in the .conf file there is no backup occurring.

Since there doesn’t seem to be much left to try, did you check this for the user the Gateway service is running? IIRC, the LocalSystem account cannot access network resources.

Do you mean the user that the gateway is running on? Otherwise I may need some elaboration.

If that is what you meant, then yes, the user the service is running on does have access to the folder.

The only thing I could think of now is that the server is a VM. Would that alter anything?

To make shared drives available to Ignition on startup, place the following lines in the ignition.conf file, which is located in the data folder of the main Ignition installation folder (usually C:\Program Files\Inductive Automation\Ignition\data for Windows users):

//Note that target "Z:" is the drive letter assigned to the mapped drive.
  
wrapper.share.1.location=\\fileserver\folder
wrapper.share.1.target=Z:
wrapper.share.1.type=DISK
 Then Stop the Gateway and Start the Gateway. **Restarting does not enable this functionality**.

Change the appropriate data for location and target to match the computer's actual setup. If your shared drives require authentication, add the following lines, filling in the appropriate data for user, domain, and password:

wrapper.ntservice.account=user
wrapper.ntservice.password=password
wrapper.share.1.account=domain\user
wrapper.share.1.password=password

This is from manual… and like @pturmel said in second post…

1 Like

That’s exactly what I have been doing.

Consider getting support to look at what you’re doing via a remote session.

Good tip.

Thank you all for the suggestions!

I think your problem is the user under which Ignition is running.
Because Ignition is running as a service it must be running under the local system account, so that it can run also, when nobody is logged-in the computer.
But local system account doesn’t have access to network resources (shares). That’s why you must run Ignition service under the account that has access to the network share.

And that is what is done with this setting in the ignition.conf:
wrapper.ntservice.account=user
wrapper.ntservice.password=password

Here you must put the user (and password) which has access to the network share.
And on both computers (where the Ignition is running and where the network share is) this user must be created (under Manage Computer/Local Users and Groups/Users) with the same password.
Unless both computers are under domain…