New components can't be moved or modified in Perspective Designer

Hi,
I’m trying to add new components to a Perspective view that uses a coordinate container but after I add the compoinent and want to move it or modify it the Designer won’t let me do it. I keeps on getting back to the position where it landed and the proportion are impossible to modify.
I can move components that already exist but if I copy them they are stuck.
The original page is not my design, could it be that there’s some strange property that I have to turn off?
I tried to press Alt while moving the objects but all it does it gets rid of the red lines. I found this behaviour is on different machines, the Vision part of the project doesn’t have this behavior.
Thi is very frustrating, I hope you can help me.
Thanks

Most probably aren’t going to download the video. It would be easier and better to attach the actual view.

Hold SHIFT, right click on the view and COPY JSON. Post the code here, using preformatted text.
image

The file is too long, I can’t paste it here. I copied it into a file
CALUSCO_Json.txt (54.0 KB)

1 Like

Probably not the answer you are looking for, but I pasted your view (using 8.1.17) and I am able to move components around.

If you don’t get much traction here you may want to call support and have them take a look.

1 Like

Ok, thank you.

If you hold down ALT while moving does that change anything?

tried restarting the designer? xd

No

I tried to copy the JSON code into a new View and the new view doesn’t display that strange behaviour, I’ m going to recreate the Views in this way

1 Like

Hi @daniele1,
I experience same behaviour with some perspective components.
How did you solve it? just creating a new view?
thanks

Hi @Maria_P ,
yes I created a new view, if I remember correctly in a text editor I created a file with the new view in wich a copied the JSON code of the old one and then I imported it into the project.