Nexus repository very slow

Hello,

I am just starting to convert a module to use the new maven build, and I am experiencing very slow downloads from the nexus repository. Am I the only one experiencing this? I am located in Brisbane, Australia

Cheers

Nicolas

Just to give an idea about what I mean by slow: downloading the metadata only from the nexus repository took more than one hour (I cancelled before it was the end). So this is not really workable, specially when using the snapshots “mode” which download the metadata on each build.

Hi @Kevin.Herron , is it normal that actually the nexus repository isn’t accessible?
Maven can’t synchronize all plugin and now after a ‘clean’ command i have this exception when i execute ‘package’ cmd:

[ERROR] Failed to execute goal com.inductiveautomation.ignitionsdk:ignition-maven-plugin:1.0.9:modl (execution1) on project OpcUaFctAddon-build: Execution execution1 of goal com.inductiveautomation.ignitionsdk:ignition-maven-plugin:1.0.9:modl failed. NullPointerException -> [Help 1]

thank

Why do you think that error is because the Nexus repository isn’t accessible?

Can you run mvn package -X and get more info?

the Nexus repository connection is in time out when i update my maven repository:

http://nexus.inductiveautomation.com:8081/nexus/content/repositories/inductiveautomation-releases
http://nexus.inductiveautomation.com:8081/nexus/content/repositories/inductiveautomation-snapshots
http://nexus.inductiveautomation.com:8081/nexus/content/repositories/inductiveautomation-thirdparty

Are none of those URLs reachable for you?

None of URL is reachable

With maven -X option:
Could not transfer metadata com.bouyguesenergiesservices:OpcUaFctAddon-client:1.0-SNAPSHOT/maven-metadata.xml from/to releases (http://nexus.inductiveautomation.com:8081/nexus/content/repositories/inductiveautomation-releases): Connect to nexus.inductiveautomation.com:8081 [nexus.inductiveautomation.com/207.173.23.101] failed: Connection timed out: connect

@mazeyrat has the same error on his platform.

You may have some kind of DNS or other connection issues going on. They were reachable for me this morning from home and are reachable now at the office. It’s also reachable from my cellphone (not on WiFi).

You can run Maven commands with the -o flag to run in offline mode.

1 Like

@Kevin.Herron well done!

Until the last maven update we change our Firewall and this role wasn’t recreate.

Thanks lot