No longer support OPC DA?

In 8.1.7, the OPC configuration included support for legacy OPC DA, which is what Rockwell Linx uses:

I installed 8.1.18 and now see there is no support for OPC DA:

Does this mean there is no longer support for legacy OPC DA, or is there another way to do it?

Did you install the OPC COM module? (It isn’t part of a standard install.) That’s what makes OPC DA connections possible. (And only if the gateway is running on Windows.)

My gateway is Mac OS Monterey

Your Mac could make OPC DA connections in the past?

I don’t think I tried it in the past, I just know that I no longer see the OPC DA option in configure. I have Win7 and Win10 VMs on older releases showing that option

OPC DA is a Windows-only legacy technology. That’s why OPC/UA was created.

1 Like

Will OPC Comm even work after the DCOM hardening patch is applied in March 2023?

Maybe?

Taken from
https://rockwellautomation.custhelp.com/app/answers/answer_view/a_id/1133982

Classic OPC-DA communications utilizes DCOM communications to pass information between workstations. FactoryTalk® Services include an OPC-DA client interface that enables many FactoryTalk-enabled software products to exchange data with third-party OPC-DA servers. Similarly, FactoryTalk® Linx Gateway and RSLinx® Classic function as an OPC-DA server. The DCOM authentication level elevation impacts all OPC-DA communications from these products and any third-party OPC-DA clients and servers running on different workstations (Note OPC-DA communication within one workstation or OPC UA communication are not affected). OPC-DA Clients and Servers must utilize the same DCOM authentication level. Once the FactoryTalk-enabled software DCOM authentication level is changed the DCOM authentication level used by third-party clients and servers on remote workstations must also be updated.

Temporary Workaround
Following application of Microsoft’s June 14, 2022, Windows cumulative update, and until Rockwell Automation product patches are available, use the temporary workaround Microsoft describes in MS KB5004442 to disable the Microsoft DCOM Hardening patch.

It’s not discontinued, it does still work after the patch, though you may need to tweak settings on the server if it’s DCOM vs COM, and the module has never worked on Mac - Windows only.

Is this OPC-UA Module (17.286495208740234MB)? If not, where do I find that module to download it

You already have the OPC UA module installed, else you would not have been presented with the option to create an OPC UA connection.

You find the OPC COM module on Ignition’s regular download pages.

But it isn’t going to work on your Mac, if that is what you want to try.

The confusion was that OPC-DA was missing in the configuration dialog, but I did not realize Ignition was smart enough to know it was installed on Mac instead of Win. I now have upgraded Ignition to 8.1.18 on my Win7 VM and it shows both UA and DA options in the dialog.

The issue I now have is that I cannot get OPC working between my 2 VMs. The host is Win10 with Linx Gateway for my code running in Emulate slot 3.

From my Win7 VM I can ping the Win10 host, but cannot get a device connection or OPC DA connection to work.

For device connection, the status toggles Connecting to ConnectWait, never connects:


For OPC DA connection the status is Fault:



Now I have communication from a test client, but not Ignition

On my Win10 VM host I have Emulate running with FTLinxGateway:

On my Win7 VM client machine, I have the Unified Automation test client connected to FTLinxGateway on the Win10 VM and can browse and display tags from Emulate:

However, from the Win7 VM if I use FactoryTalkLinxGateway as the ProgID:

it is faulted:

Am I using the wrong ProgID? What should I use?

I figured it out!

Instead of DA, I configured UA. I used the Unified Architecture test client to get the endpoint, which is the FactoryTalkLinxGateway server:

I configured the OPC UA connection with this endpoint in Ignition:

It connected!

Now I can browse tags in Emulate on my other VM:

Thanks everyone for helping me solve the problem.