NoClassDefError coming from an External JAR

Morning all. If I have put this question in the wrong section of the forum. I am running an external JAR file as a library for RFID tag readers with Ignition. I have had two systems running this JAR file, with an identical jython script on each system. Same .proj file, same Ignition version (7.9.4) and same Java version (8u_121). On one system it runs fine, but on the second system, I get a NoClassDefError when the import statement is called up. Linked below is the output from the Java console when the script is called(New users cannot upload attachments :confused: ). I have tried windows updates, JAVA version updates, repacking the JAR (incase it got corrupted during transfer). I can run the java file standalone as well. Any advice or pointers would be much appreciated.

Is this two separate gateways?
Did you place the JAR file in: “C:\Program Files\Inductive Automation\Ignition\lib\core\common” (windows machine) in each gateway?

Yes, two seperate gateways. Both have the jar and packed jar in the same location (C:\Program Files\Inductive Automation\Ignition\lib\core\common)

Which jar supplies ?

The jar that should be supplying it is com.lievautomation,jar. That is the custom jar that I packaged the source into

Please look in the jar and make sure.

A quick google suggests you need to separately install the RXTX package. As an LGPL licensed project, a commercial user would have to take special steps to ship this themselves, restrictions that are difficult for third parties to satisfy in Ignition.

Thanks for the info pturmel. Forgive me, as I am a bit new with ignition, but how would I go about installing the RXTX Package for ignition?

I have figured out installing the DLL and JAR, thank you for pointing me in teh right direction on that one. Now I am just running into the issue of it being a 32 bit dll on a 64 bit system. I’ll do some research on what I can do to fix that. Thanks!

Maybe the folks who produced the liveautomation jar file can support you.

So, the issue was the rxtx serial dll being compiled for 32 bit. Running 32 bit java resolved that issue, and based on the usage, doesn’t cause any other issues. Thanks for all the help in getting this solved.