Node-Red for Maker

Has anyone gotten this to work? I see that Travis has forked the node-red Ignition to add Maker support.
https://github.com/IgnitionModuleDevelopmentCommunity/IgnitionNode-RED/tree/maker

I downloaded that module file and installed to the gateway. I installed Node red by following the instructions found here. I created a string tag just to try to read and write to under the default tag provider.

I installed the ignition read/write module to the pallet, setup a very basic flow to try and read the string tag I created. When triggering the flow, I get a JSon error. Any ideas?

My config of the server for Ignition is as follows below.
image
I have even tried usiing the specific IP address of the machine running Ignition as well with the same results.

2 Likes

Im going to try it soon. But im sure that im going to stick with sparkplug via nodered.
If you use mqtt sparkplug between ignition and nodered, actually polulate the ignition tag provider through the mqtt engine. Everytime you create a “tag” in nodered.

The node red sparkplug nodes can be found here. https://flows.nodered.org/node/node-red-contrib-sparkplug

I got node red running on my jetson nano and I can control the GPIO pins.
How do I install the node red module for maker?
I dont see any install instructions in the IgnitionNode-RED github repo

The module is located in the root of the repo - Ignition-Node-RED-Module-signed.modl.

I am having the exact same issue: JSON error: SyntaxError: Unexpected end of JSON input

I am struggling to find the API token and the secret. I have went through everything on the gateway web server (i know the location is on the GitHub but I have nothing pertaining to Node-Red.

Once you install the node-red Ignition module, you’ll set it up on the Configuration area of the gateway web page. It has it’s own section down at the bottom. When you enter the API token it needs to be 16 characters as stated, no more, no less, otherwise it’ll fail without explanation.

Once you have that set up, just go to node-red and set up that end with the API token and secret.

2 Likes

Seems like the node-red module kept crashing until i did a full restart of the RPI4. However, One thing I’m struggling with is the tagging. Node-Red can’t find the tag from ignition.

I’m trying to install the module but I’m receiving this error.

Did you switch to the maker branch in GitHub before downloading? I’m guessing you installed the version from the master branch.

I realized that as soon as I sent the message… whoops. Installed the maker branch and it works.Thanks

Is there any answer to the OP’s actual question? Most of these topic replies are all about everyone else’s issues…