Not able to do import in Tags v.8

Why is the import tag not working?
the only way to get the tag working is to do a browse and then the tag works, importing does not work. Should I go to version 7.9, at least it worked, but my license is now version 8 for the new sites. Upgrading a software is always good, but the testers should earned their money.

Version 8 is not working, anyone can help on this, this is really something.
And BTW, after the browse, the OPC item path is exactly the same.



1 Like

What? What does that mean, what is it that you did not understand about importing a tag?
I can modify the OPC Item path manually and this doesn’t work, but if I use the browse, the button at the end of the OPC Item Path and choose it (It is the same as what I typed before) and click commit, then OK, now the tag works, why?

What version of 8 are you using? Importing OPC tags seems to work just fine for me.

Well, you are certainly a lucky person.
Version is 8.0.4 (b2019091612)

Also added two pictures, the first on is a manual OPC tag or imported tag, the second one, I just clicked on the browse button on the OPC Item Path to get the same tag, of course the screen is the same because it is the same tag. But now it works. I am not about to do this on 2000 tags for each sites.

The OPC Server in your two screenshots is different…

Must be getting old.

It was an unfortunate oversight in 8. Fresh installs use “Ignition OPC UA Server” in 8, where it was hyphenated in prior versions.

If you were to just upgrade a 7.9 system everything would be fine, but tag imports from 7.9 need to be find/replaced on that server name if being imported into a fresh 8 install.

I had the same issue! Did the name of the default OPC server change from previous versions with the -?

Yes, see above. It got caught up in a big sweep where I changed all the references I could find from “OPC-UA” to “OPC UA”.

Didn’t catch this particular one until after release, and even then didn’t realize how many people would be doing piecemeal tag imports from 7.9 systems instead of just upgrading.


Ok, so I have 9 sites to install.
The install is from a fresh copy of Ignition 8.0.4 (same .exe)
How do you explain that site one, the browser shows “OPC-UA”, and then on the second site it shows “OPC UA”, what will be the name used on my third install?
The only difference is the license number and of course the tag list.

This is a problem, yes I have a fix, but why is it different?

If you’re talking about the name of the OPC UA connection in the gateway the only possibility is that one site is an upgrade from 7.9 (or gwbk restore) or someone modified the the OPC UA connection name.

If you’re talking about what you name see in an OPC tag, then it depends if the tag came from an import or was created brand new or via drag-n-drop.

Huh. How far back is this one? :slight_smile:


From a long-term standpoint, should I consider renaming it to the current default name and Find/Replace the tags using it? Not sure what benefit it would have outside of trying to future-proof things.

Ha, yeah, that default name is even older! Funny, there weren’t any issues back when it changed from that one.

I don’t think it matters what the name is as long as you’re aware that your import/exports need to have the right name in them.

I have the same problem. Being rather new to Ignition in general and Ignition 8 in particular how do i change the OPC server name and do a search and replace on all my tags?


EDIT: I was able to fix this by doing a search and replace on my exported tags.xml file with the correct server name using Notepad++. Not sure if that’s the recommended way but it worked for me.

1 Like

Notepad++ is one of my favorites, although I was thinking of Ignition’s Find/Replace tool.

That said, the context of your post doesn’t match anything else in the thread. :confused:

I tried the Ignition search and replace and it didn’t work for me. I find it kind of confusing and there didn’t seem to be a way to just search tag properties. But in any case, all is good now.

1 Like