Not able to write to MQTT tags from ignition

Hello All,

Currently using an Automation Direct BRX PLC and publishing data to my Chariot SCADA broker in my distributor module. I’ve been able to create a custom namespace on engine and get my tags to auto-populate. I noticed that they are all read-only though. After turning off block property changes, node commands, and device commands, they are still read only. I checked my ACL on my distributor and it is RW # as well. Everything is connected properly as well.
I tried to use the transmission module, and my folders would create, but no tags would be in them. Any push in the direction I need to go?

All help is appreciated.

I’m pretty sure custom namespaces are read-only and you can only publish to topics in a custom namespace via system.cirruslink.engine.publish. There should be an advanced option to make the Ignition tag created for each topic in that custom namespace writable, but that’s just modifying the local value, not publishing anything.

Thanks for your reply. I think I was misunderstanding how the transmission module worked. What I’ll do is more than likely create interface UDTs and route them through the transmission module so that they can interface with what the PLC is subscribed to.