Not able to write to OPC-UA tags from Ignition


We have established the communication to UA gateway wrapper from Ignition Gateway. The problem is we are able to read all the signals without any error, but are not able to write from Ignition.

It just shows the below error when trying to write from the designer session.

I have checked the below settings

  1. Read only setting is disabled for the OPC-UA connection
  2. Read only setting is disabled for the tag
  3. Security level is public for the tag
  4. Connection is healthy, there are no logs in the gateway

Can anyone expert from here help me to resolve the problem?

Note: The tags which we are trying to write were working properly before. Suddenly this issue pops up to bother us :slight_smile:

Thanks in advance!!

If you write from the OPC Quick Client in the gateway do you also get a bad StatusCode in return?

Hello @Kevin.Herron ,

Thanks for the quick response!!

I have not tried. But the same problem during the gateway timer scripts (Gateway scope)


If you still get a bad StatusCode when writing from the QC or via system.opc.write* then you can be sure the StatusCode is coming from the server and not as a result of some Ignition configuration, and you need to be looking outside Ignition (the UA gateway or the server behind it) to figure out why it’s failing.

I have tried system.opc.write, getting False as the write status

As you have rightly pointed out, I am also checking the other side. Is there a possibility the write could be prohibited because of the OPC-UA client certificate of ignition?

Just a quick question though: Why there is no detailed error message? Just it shows “Bad” when tried from designer session

What version of Ignition are you using?

Version: 8.1.5 (b2021042810)

Hmm, then I think the StatusCode returned by the server is either just generic “Bad” or it’s one that we have not mapped to an Ignition QualityCode.

edit: it looks like starting in 8.1.12 we did add a little more detail when it’s an un-mapped StatusCode, though.

1 Like

Is there a possibility the write could be prohibited because of the OPC-UA client certificate of ignition?

No, that would prevent the connection from being made all together.

That’s correct, my intuition is also the same!

I will check the UaGateway wrapper side.

Thanks for your great support!

It would be good to get Ignition upgraded at some point too. You should have a better diagnostic message in this case, along with all the other fixes/changes.

We have recently upgraded the version for this site, I will check if possible.