NOTICES overlay on Perspective Flex Repeater obscuring part of the view

If we have a comms error on one of the machines in this Flex Repeater view the overlay warnings appear on the controls (and that’s good) but the NOTICES banner obscures the last machine in the list - AC8 in this case.

Is there a way to disable the NOTICES footer without opting out of the overlays?

Many thanks.

i have never seen this overlay as white.

found em:

.ia_qualityOverlay__footer–unknown: white
.ia_qualityOverlay__footer–error: red
.ia_qualityOverlay__footer–pending: green

i guess you could turn this one invisible… No idea if this is the one you would want though.

.ia_qualityOverlay__footer--unknown{display: none}

You might also only want to target your specific components… probably safer to do it by assigning a class
.psc-noUnkownNotices .ia_qualityOverlay__footer--unknown{display: none}

I had never seen the white overlay either - it’s normally red. I wanted to demonstrate the problem so I disabled the PLC device connection for a few minutes. Lo and behold! The overlay was white.

Thanks for your (solve everything with) CSS approach. I’ll wait a while and see if any alternatives are suggested.

One thing that surprised me was that the notices appears on the flex repeater rather than on the individual instances. Does anyone know how this gets pass up to a higher level?

I think the repeater is “smart” enough to roll up quality warnings from lower components. Or something like that; I don’t know the exact mechanism by which it works.

I’ve implemented a workaround for now. On the Flex Repeater:
props.style.paddingBottom: 22.

The NOTICES now appear below the bottom machine.

2 Likes