NULL values on RS Linx tags

I am able to browse to tags in an RS Linx topic, but the values are showing up NULL.

The Rockwell OPC test client shows the values correctly, so I know that OPC is “working”. Since I can browse from Ignition, it can see the tags. However, when it performs a read the status is NOT CONNECTED and the value NULL. I followed the instructions in (setting COM security to have all privileges for Everyone and Anonymous) but that did not fix it.

The photos tell the story. Any ideas?

SOLVED! I don’t know the repercussions other than perhaps diminished performance, but unselecting “Use Async Operations” fixed it and now I have live data

I had a premature celebration. The test client works but Ignition tag browser still shows NULL data. Help!

It appears the tags are in a scan class that is running, since the Last Execution is updating. However it is getting a bad status despite the fact that the OPC quick client gets a good value. I don’t see how this is possible, but obviously it is happening.

A solution has been found

The tags were assigned to subscribe, which is the preferred approach. However, it appears the subscription through OPC to RS Linx Gateway 4.00.00 was not working. Changing from subscription to read gave me good values. This is not optimal, but it is working.

An important update: Rockwell Emulate cannot handle asynchronous communications.

I was getting null values in Designer and Ignition OPC client while Kepware OPC client was giving good values on the same tags. It turns out Kepware uses synchronous communications by default. Ignition by default enables Ignition’s OPC setting :” Use Async Operations”. Ignition was trying asynchronous reads because the checkbox was checked. This was giving “not connected” errors even though we could browse. By unchecking the option we get good values. This is unique to Rockwell Emulate. A real PLC can handle asynchronous communication.

There was a clue found on the Kepware support site Support Center | Customer Resources | Kepware