Numeric component problem

Hi!

I can’t enter a decimal value in the way we use in sweden, like 1,23. I tried to change the decimal pattern from ###.## to ###,### but that does not work.

How can i change the behavior so it accept my local setting of a decimal value?

The decimal format pattern itself is locale independent, so the . is the format for the decimal separator, even if your locale’s decimal separator is a ,.

To get the numbers to display correctly for your locale, you need to set the locale. Either use a language selector component and choose Sweden, set the client to start up in that locale, or have the designer preview in that locale. Some doc pages that can help: Localization and Languages, Switching the Current Language and Language Selector

My locale is already Sweden. The ignition app is setup to use Sweden. The problem is that it displays the decimal number correctly, with our ‘,’ as decimal point. But I can’t enter a new number with our point. I must use a ‘.’ to get it to accept my new number.

So, you’re trying to enter a decimal using the number pad, but the key is entering as the wrong character?
We have an internal ticket to add an option to Vision clients to treat numpad input ‘.’ as locale-dependent decimal separator - would that meet your needs?

The decimal point on swedish keyboards are , and not .